Bug #66557 [Fbk->NoF]: modules/libphp5.so: symbol unixd_config: referenced symbol not found

From: Date: Sun, 13 Jun 2021 04:22:13 +0000
Subject: Bug #66557 [Fbk->NoF]: modules/libphp5.so: symbol unixd_config: referenced symbol not found
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-234379@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=66557&edit=1 ID: 66557 Updated by: php-bugs@lists.php.net Reported by: iand at ekit-inc dot com Summary: modules/libphp5.so: symbol unixd_config: referenced symbol not found -Status: Feedback +Status: No Feedback Type: Bug Package: Reproducible crash Operating System: Solaris 9 PHP Version: 5.5.8 Assigned To: cmb Private report: N New Comment: No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Re-Opened". Thank you. Previous Comments: ------------------------------------------------------------------------ [2021-05-31 12:53:12] cmb@php.net If this issue is still unresolved, could someone please provide a pull request[1] for better visibility? [1] <https://github.com/php/php-src/pulls> ------------------------------------------------------------------------ [2016-08-15 07:23:12] nikolai dot denissov at gmail dot com I wonder if it would be possible to get compiled libphp5 | 7 compatible with Apache 2.4.x somehow? ------------------------------------------------------------------------ [2014-05-12 22:58:26] zaqdev84 at gmail dot com Any chances of this bug being fixed in any future releases? ------------------------------------------------------------------------ [2014-01-23 00:24:51] iand at ekit-inc dot com Description: ------------ Compiled Apache 2.4.6 with php 5.5.8; builds ok but at run time, php load fails with this: httpd: Syntax error on line 56 of /opt/local/apache/conf/httpd.conf: Cannot load modules/libphp5.so into server: ld.so.1: /opt/local/apache/bin/httpd: fatal: relocation error: file /opt/local/apache/modules/libphp5.so: symbol unixd_config: referenced symbol not found This is because sapi/apache2handler/php_functions.c tests for the new name for unixd_config (ap_unixd_config) using a check on MODULE_MAGIC_NUMBER_MAJOR but it doesn't include the header file that includes that definition. Fix is trivial: include ap_mmn.h Seems lots of people have reported this on various OS's but a search of the bug repo for unixd_config doesn't show anything. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=66557&edit=1

« previous php.bugs (#234379) next »