#19276 [NEW]: Udefined symbol: core_globals
| From: | deadsman at hotmail dot com | Date: | Sat, 07 Sep 2002 13:02:37 +0000 |
| Subject: | #19276 [NEW]: Udefined symbol: core_globals | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-18611@lists.php.net to get a copy of this message | ||
From: deadsman@hotmail.com
Operating system: redhat 7.3
PHP version: 4.2.3
PHP Bug Type: Apache related
Bug description: Udefined symbol: core_globals
Hi,
when I try to start apache whit php4 library, Apache 1.2.26 give me his
error:
[root@lambda php-4.2.3]# apachectl start
Syntax error on line 205 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/libphp4.so into server:
/usr/lib/apache/libphp4.so: undefined symbol: core_globals
/usr/sbin/apachectl start: httpd could not be started
The line for configuring apache and php is:
PHP:
./configure --with-mysql --with-apxs=/usr/sbin/apxs
--with-config-file-path=/usr/local/lib/php --enable-dbase
APACHE:
./configure --with-layout=RedHat --enable-module=all
--disable-module=auth_db --disable-module=auth_dbm
I have this problem whit other version of PHP like 4.2.1 and 4.2.2 .
Thx & Bye.
--
Edit bug report at http://bugs.php.net/?id=19276&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=19276&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=19276&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=19276&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=19276&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=19276&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=19276&r=support
Expected behavior: http://bugs.php.net/fix.php?id=19276&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=19276&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=19276&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=19276&r=globals