#19290 [Opn->Fbk]: NSAPI version compile fails, configure says ".../plugins: does not exist"

From: Date: Sun, 08 Sep 2002 18:15:02 +0000
Subject: #19290 [Opn->Fbk]: NSAPI version compile fails, configure says ".../plugins: does not exist"
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-18676@lists.php.net to get a copy of this message
ID: 19290 Updated by: kalowsky@php.net Reported By: fillmore@NRCan.gc.ca -Status: Open +Status: Feedback Bug Type: Compile Failure Operating System: Solaris 8 PHP Version: 4.2.3 New Comment: Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip I think I see whats wrong. Any chance you can test out an unstable snapshot dated sometime after now. I just put in a fix which I hope corrects this issue for you. If it does, I'll back port it to 4.2 branch as well Previous Comments: ------------------------------------------------------------------------ [2002-09-08 12:55:12] fillmore@NRCan.gc.ca Here are a few lines before/after the configure error: checking for FastCGI support... no checking for Zeus ISAPI support... no checking for NSAPI support... /suitespot checking for NSAPI include files... iPlanet/4.x style ./configure: -I/suitespot/plugins: does not exist checking for PHTTPD support... no checking for Pi3Web Support... no The iPlanet NSAPI include directory is /suitespot/plugins/include The problem is that the configure script is checking to see if the directory "-I/suitespot/plugins" exists. The "-I" shouldn't be included in a path check! (the 4.2.2 configure script didn't have this bug) - Bob ------------------------------------------------------------------------ [2002-09-08 12:22:18] kalowsky@php.net Can you please post the few lines output'ed from configure before this error occurs? The -I just adds another include directory and should not be the problem. Whats of concern is that the check for the $custom_dir/include is apparently failing, and screwing things up. Do you have a /suitespot/include directory by chance? ------------------------------------------------------------------------ [2002-09-08 10:06:42] fillmore@NRCan.gc.ca When running configure in the 4.2.3 release, as follows: CC=gcc ./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/ph p/etc --with-nsapi=/suitespot --enable-libgcc --enable-dbase --with-xml an error message is issued: ./configure: -I/suitespot/plugins: does not exist and the make fails with errors about not being able to find the NSAPI include files. (iPlanet 4.x style) Looks like 4.2.3 introduced a bug in the configure script- the NSAPI include path now contains the string "-I". I changed the configure script to restore the NSAPI code to the 4.2.2 version, and it now does configure/make properly. Here is my change to the configure script: nrn1# diff configure configure.0 4387c4387 < NSAPI_INCLUDE="$PHP_NSAPI/plugins/include" --- > NSAPI_INCLUDE="$NSAPI_INCLUDE -I$PHP_NSAPI/plugins/include" - Bob Fillmore ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19290&edit=1

« previous php.bugs (#18676) next »