#19290 [Csd->Opn]: NSAPI version compile fails, configure says ".../plugins: does not exist"
| From: | fillmore at NRCan dot gc dot ca | Date: | Sun, 29 Sep 2002 19:33:23 +0000 |
| Subject: | #19290 [Csd->Opn]: NSAPI version compile fails, configure says ".../plugins: does not exist" | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-20686@lists.php.net to get a copy of this message | ||
ID: 19290
User updated by: fillmore@NRCan.gc.ca
Reported By: fillmore@NRCan.gc.ca
-Status: Closed
+Status: Open
Bug Type: Compile Failure
Operating System: Solaris 8
PHP Version: 4.2.3
New Comment:
I tried compiling the latest version from CVS (200209290900),
and it still fails.
Here are a few lines from the configure output:
checking for FastCGI support... no
checking for Zeus ISAPI support... no
checking for NSAPI support... /suitespot
checking for NSAPI include files... iPlanet/4.x style
checking for /suitespot/plugins/include/nsapi.h... yes
./configure: -I/suitespot/plugins: does not exist
checking for PHTTPD support... no
checking for Pi3Web Support...
Here are the compile errors:
/bin/sh libtool --silent --mode=compile gcc -Isapi/nsapi/
-I/home8/src/php/beta
/php4-200209290900/sapi/nsapi/ -DPHP_ATOM_INC
-I/home8/src/php/beta/php4-2002092
90900/include -I/home8/src/php/beta/php4-200209290900/main
-I/home8/src/php/beta
/php4-200209290900 -I/include
-I/home8/src/php/beta/php4-200209290900/Zend -I/ho
me8/src/php/beta/php4-200209290900/ext/xml/expat
-D_POSIX_PTHREAD_SEMANTICS -D_
POSIX_PTHREAD_SEMANTICS -D_REENTRANT
-I/home8/src/php/beta/php4-200209290900/TSR
M -DTHREAD=1 -g -O2 -pthreads -DZTS -prefer-pic -c
/home8/src/php/beta/php4-20
0209290900/sapi/nsapi/nsapi.c -o sapi/nsapi/nsapi.lo
/home8/src/php/beta/php4-200209290900/sapi/nsapi/nsapi.c:50: nsapi.h:
No such fi
le or directory
/home8/src/php/beta/php4-200209290900/sapi/nsapi/nsapi.c:51:
base/pblock.h: No s
uch file or directory
/home8/src/php/beta/php4-200209290900/sapi/nsapi/nsapi.c:52:
base/session.h: No
such file or directory
/home8/src/php/beta/php4-200209290900/sapi/nsapi/nsapi.c:53:
frame/req.h: No suc
h file or directory
/home8/src/php/beta/php4-200209290900/sapi/nsapi/nsapi.c:54:
frame/protocol.h: N
o such file or directory
/home8/src/php/beta/php4-200209290900/sapi/nsapi/nsapi.c:55:
base/util.h: No suc
h file or directory
/home8/src/php/beta/php4-200209290900/sapi/nsapi/nsapi.c:56:
frame/log.h: No suc
h file or directory
*** Error code 1
make: Fatal error: Command failed for target `sapi/nsapi/nsapi.lo'
Thanks,
Bob Fillmore
Previous Comments:
------------------------------------------------------------------------
[2002-09-26 19:57:02] sniper@php.net
This bug has been fixed in CVS.
In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.
------------------------------------------------------------------------
[2002-09-08 13:15:02] kalowsky@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-latest.zip
I think I see whats wrong. Any chance you can test out an unstable
snapshot dated sometime after now. I just put in a fix which I hope
corrects this issue for you. If it does, I'll back port it to 4.2
branch as well
------------------------------------------------------------------------
[2002-09-08 12:55:12] fillmore@NRCan.gc.ca
Here are a few lines before/after the configure error:
checking for FastCGI support... no
checking for Zeus ISAPI support... no
checking for NSAPI support... /suitespot
checking for NSAPI include files... iPlanet/4.x style
./configure: -I/suitespot/plugins: does not exist
checking for PHTTPD support... no
checking for Pi3Web Support... no
The iPlanet NSAPI include directory is /suitespot/plugins/include
The problem is that the configure script is checking to see
if the directory "-I/suitespot/plugins" exists.
The "-I" shouldn't be included in a path check!
(the 4.2.2 configure script didn't have this bug)
- Bob
------------------------------------------------------------------------
[2002-09-08 12:22:18] kalowsky@php.net
Can you please post the few lines output'ed from configure before this
error occurs?
The -I just adds another include directory and should not be the
problem. Whats of concern is that the check for the
$custom_dir/include is apparently failing, and screwing things up.
Do you have a /suitespot/include directory by chance?
------------------------------------------------------------------------
[2002-09-08 10:06:42] fillmore@NRCan.gc.ca
When running configure in the 4.2.3 release, as follows:
CC=gcc ./configure --prefix=/usr/local/php
--with-config-file-path=/usr/local/ph
p/etc --with-nsapi=/suitespot --enable-libgcc --enable-dbase
--with-xml
an error message is issued:
./configure: -I/suitespot/plugins: does not exist
and the make fails with errors about not being able to find the NSAPI
include files.
(iPlanet 4.x style)
Looks like 4.2.3 introduced a bug in the configure script- the NSAPI
include path
now contains the string "-I". I changed the configure script to
restore the NSAPI
code to the 4.2.2 version, and it now does configure/make properly.
Here is my change to the configure script:
nrn1# diff configure configure.0
4387c4387
< NSAPI_INCLUDE="$PHP_NSAPI/plugins/include"
---
> NSAPI_INCLUDE="$NSAPI_INCLUDE -I$PHP_NSAPI/plugins/include"
- Bob Fillmore
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19290&edit=1