Bug #13595 Updated: Solution for "PHP Fatal error: Unable to start session mm module in Unknown on

From: Date: Thu, 07 Mar 2002 05:30:14 +0000
Subject: Bug #13595 Updated: Solution for "PHP Fatal error: Unable to start session mm module in Unknown on
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-1881@lists.php.net to get a copy of this message
ID: 13595 Updated by: mfischer@php.net -Summary: Solution for "PHP Fatal error: Unable to start session mm module in Unknown on Reported By: plafundum@yahoo.com -Status: Feedback +Status: Analyzed Bug Type: Session related Operating System: Debian Sid PHP Version: 4.0.6 New Comment: Ah .. interesting ... Did you set the save path explicitely to '/dev/null' ? (And if so, why?) All I know at the moment is that serveral session issues are adressed at the moment. Marking this as analyzed until one of our session gurus can answer this more accurat. Previous Comments: ------------------------------------------------------------------------ [2002-03-06 19:50:16] matt@mystile.com Thanks to mfischer@php.net, I found the problem using strace. I had 'session.save_path' set to '/dev/null'. Why does 4.1.2 not handle this gracefully like 4.0.5, and is there any way to get a more helpful error message in this case? In case you're interested in the exact errors, I've included the errors from the strace below: unlink("/dev/null/session_mm_apache0.sem") = -1 ENOTDIR (Not a directory) open("/dev/null/session_mm_apache0.sem", O_RDWR|O_CREAT, 0600) = -1 ENOTDIR (Not a directory) unlink("/dev/null/session_mm_apache0.sem") = -1 ENOTDIR (Not a directory) ------------------------------------------------------------------------ [2002-03-05 02:24:42] mfischer@php.net An other alternative would be to use use 'strace' on the apache process (make sure you start apache with -X switch), maybe you can gather where it has failed, e.g. strace -e trace=file -o output /usr/sbin/apache -X and see in file 'output' what fails. ------------------------------------------------------------------------ [2002-03-05 02:17:02] derick@php.net Can you try a snapshot from snaps.php.net? It might be fixed, if not we need feedback on that branch anyways. regards, Derick ------------------------------------------------------------------------ [2002-03-05 01:48:33] matt@mystile.com I'm seeing this problem on Slackware 8.0, when upgrading from the original mod_php.tgz package (PHP 4.0.5) to the updated version (PHP 4.1.2). I already checked, there is no 'session_mm.sem' file to remove (stopping apache automatically removes the file). So my question is, what is going on, and how do I fix it? ------------------------------------------------------------------------ [2001-11-11 12:37:22] sander@php.net So it's not a bug in PHP. Thanks & Closing... ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/13595 -- Edit this bug report at http://bugs.php.net/?id=13595&edit=1

« previous php.bugs (#1881) next »