#19310 [Opn->Fbk]: can't open a file on remote server

From: Date: Mon, 09 Sep 2002 15:40:54 +0000
Subject: #19310 [Opn->Fbk]: can't open a file on remote server
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-18810@lists.php.net to get a copy of this message
ID: 19310 Updated by: sniper@php.net Reported By: rose.gao@specialreserve.net -Status: Open +Status: Feedback Bug Type: HTTP related Operating System: FreeBSD4.4 PHP Version: 4.2.3 New Comment: You're still referring to 4.2.1...so which version is it? Check from phpinfo() output..and are you sure it's not something wrong with the included file? ie. maybe there is some network problem at the time? Previous Comments: ------------------------------------------------------------------------ [2002-09-09 08:25:14] rose.gao@specialreserve.net I have just built a new web servers to replace old one. They are running FreeBSD 4.4 with Apache 1.3 and PHP 4.2.1 (compiled with mysql, pspell and pdf libs).The old one was Linux machine. When I include file with http, e.g include(http: //www.php.net/folder/file.include) there is an error : "php_hostconnect: connect failed". This happens at random times(roughly every 4-4 refreshes) and only happens when we include files with "http" ------------------------------------------------------------------------ [2002-09-09 08:14:30] sniper@php.net Thank you for taking the time to report a problem with PHP. Unfortunately you are not using a current version of PHP -- the problem might already be fixed. Please download a new PHP version from http://www.php.net/downloads.php If you are able to reproduce the bug with one of the latest versions of PHP, please change the PHP version on this bug report to the version you tested and change the status back to "Open". Again, thank you for your continued support of PHP. ------------------------------------------------------------------------ [2002-09-09 08:10:22] rose.gao@specialreserve.net I have just built a new web servers to replace old one. They are running FreeBSD 4.4 with Apache 1.3 and PHP 4.2.1 (compiled with mysql, pspell and pdf libs).The old one was Linux machine. When I include file with http, e.g include(http: //www.php.net/folder/file.include) there is an error : "php_hostconnect: connect failed". This happens at random times(roughly every 4-4 refreshes) and only happens when we include files with "http" ------------------------------------------------------------------------ [2002-09-09 07:19:00] cynic@php.net Not enough information was provided for us to be able to handle this bug. Please re-read the instructions at http://bugs.php.net/how-to-report.php If you can provide more information, feel free to add it to this bug and change the status back to "Open". Thank you for your interest in PHP. ------------------------------------------------------------------------ [2002-09-09 07:13:04] rose.gao@specialreserve.net I have just built a new web servers to replace old ones. They are running FreeBSD 4.4 with Apache 1.3 and PHP 4.2.1 (compiled with mysql, pspell and pdf libs). They seem to be fine in testing but when they go live we get intermitant faults. At random times (roughly every 4-5 refreshes) one of the includes on the page gives up the error "php_hostconnect: connect failed". This only happens when we include files over a http:// connection and not when we include directly. We have tried using both host names and IP addresses and neither seem to help. Any ideas? ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19310&edit=1

« previous php.bugs (#18810) next »