#19310 [Opn->Bgs]: can't open a file on remote server

From: Date: Mon, 09 Sep 2002 16:16:10 +0000
Subject: #19310 [Opn->Bgs]: can't open a file on remote server
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-18820@lists.php.net to get a copy of this message
ID: 19310 Updated by: sniper@php.net Reported By: rose.gao@specialreserve.net -Status: Open +Status: Bogus Bug Type: HTTP related Operating System: FreeBSD4.4 -PHP Version: 4.2.3 +PHP Version: 4.2.1 New Comment: Thank you for taking the time to report a problem with PHP. Unfortunately you are not using a current version of PHP -- the problem might already be fixed. Please download a new PHP version from http://www.php.net/downloads.php If you are able to reproduce the bug with one of the latest versions of PHP, please change the PHP version on this bug report to the version you tested and change the status back to "Open". Again, thank you for your continued support of PHP. Please don't fool around. It really doesn't help us or you if you fake the version. And I do believe this is fixed in 4.2.3.. Previous Comments: ------------------------------------------------------------------------ [2002-09-09 11:11:36] rose.gao@specialreserve.net Yes, I am still using 4.2.1 version. I used 4.2.3 in the bug report in order to make somebody reply me. I am quite sure that there was no network problem because I have tested several times. And also the included file has no problem because when I included it without "http" it worked well. Is the 4.2.1 version has always this problem? Do you believe the new version has fixed this problem? Thank you. ------------------------------------------------------------------------ [2002-09-09 10:40:54] sniper@php.net You're still referring to 4.2.1...so which version is it? Check from phpinfo() output..and are you sure it's not something wrong with the included file? ie. maybe there is some network problem at the time? ------------------------------------------------------------------------ [2002-09-09 08:25:14] rose.gao@specialreserve.net I have just built a new web servers to replace old one. They are running FreeBSD 4.4 with Apache 1.3 and PHP 4.2.1 (compiled with mysql, pspell and pdf libs).The old one was Linux machine. When I include file with http, e.g include(http: //www.php.net/folder/file.include) there is an error : "php_hostconnect: connect failed". This happens at random times(roughly every 4-4 refreshes) and only happens when we include files with "http" ------------------------------------------------------------------------ [2002-09-09 08:14:30] sniper@php.net Thank you for taking the time to report a problem with PHP. Unfortunately you are not using a current version of PHP -- the problem might already be fixed. Please download a new PHP version from http://www.php.net/downloads.php If you are able to reproduce the bug with one of the latest versions of PHP, please change the PHP version on this bug report to the version you tested and change the status back to "Open". Again, thank you for your continued support of PHP. ------------------------------------------------------------------------ [2002-09-09 08:10:22] rose.gao@specialreserve.net I have just built a new web servers to replace old one. They are running FreeBSD 4.4 with Apache 1.3 and PHP 4.2.1 (compiled with mysql, pspell and pdf libs).The old one was Linux machine. When I include file with http, e.g include(http: //www.php.net/folder/file.include) there is an error : "php_hostconnect: connect failed". This happens at random times(roughly every 4-4 refreshes) and only happens when we include files with "http" ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/19310 -- Edit this bug report at http://bugs.php.net/?id=19310&edit=1

« previous php.bugs (#18820) next »