Bug #68379 [NEW]: Cannot load oci8 extension
| From: | tony at marston-home dot demon dot co dot uk | Date: | Sat, 08 Nov 2014 18:36:44 +0000 |
| Subject: | Bug #68379 [NEW]: Cannot load oci8 extension | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-188518@lists.php.net to get a copy of this message | ||
From: tony at marston-home dot demon dot co dot uk
Operating system: Windows 7
PHP version: 5.6.2
Package: OCI8 related
Bug Type: Bug
Bug description:Cannot load oci8 extension
Description:
------------
I am running Windows 7 with Apache 2.4.10 and Oracle 11g. After
upgrading my PHP version from 5.5.18 to 5.6.2 I can longer use the oci8
extension as my code fails with " Call to undefined function
oci_connect()". When I run phpinfo() it shows that the oci8 extension is
not loaded.
When I look in the Apache error log it shows no errors. When I look in
the Windows event viewer it also shows no errors.
This was working perfectly with PHP 5.5.18, so why should a simple
upgrade to 5.6.2 cause such a problem?
Expected result:
----------------
I expect the oci8 extension to be loaded and usable.
Actual result:
--------------
The oci8 extension is not loaded, and there are no error messages
explaining why.
--
Edit bug report at https://bugs.php.net/bug.php?id=68379&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=68379&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=68379&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=68379&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=68379&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=68379&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=68379&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=68379&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=68379&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=68379&r=support
Expected behavior: https://bugs.php.net/fix.php?id=68379&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=68379&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=68379&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=68379&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=68379&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=68379&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=68379&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=68379&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=68379&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=68379&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=68379&r=mysqlcfg