Bug #68379 [Opn->Fbk]: Cannot load oci8 extension
| From: | requinix@php.net | Date: | Sun, 09 Nov 2014 00:32:24 +0000 |
| Subject: | Bug #68379 [Opn->Fbk]: Cannot load oci8 extension | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-188523@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=68379&edit=1
ID: 68379
Updated by: requinix@php.net
Reported by: tony at marston-home dot demon dot co dot uk
Summary: Cannot load oci8 extension
-Status: Open
+Status: Feedback
Type: Bug
Package: OCI8 related
Operating System: Windows 7
PHP Version: 5.6.2
Block user comment: N
Private report: N
New Comment:
You sure you're editing the right php.ini? Use phpinfo() to check which file you should be
editing.
Previous Comments:
------------------------------------------------------------------------
[2014-11-08 18:36:44] tony at marston-home dot demon dot co dot uk
Description:
------------
I am running Windows 7 with Apache 2.4.10 and Oracle 11g. After upgrading my PHP version from 5.5.18
to 5.6.2 I can longer use the oci8 extension as my code fails with " Call to undefined function
oci_connect()". When I run phpinfo() it shows that the oci8 extension is not loaded.
When I look in the Apache error log it shows no errors. When I look in the Windows event viewer it
also shows no errors.
This was working perfectly with PHP 5.5.18, so why should a simple upgrade to 5.6.2 cause such a
problem?
Expected result:
----------------
I expect the oci8 extension to be loaded and usable.
Actual result:
--------------
The oci8 extension is not loaded, and there are no error messages explaining why.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=68379&edit=1