Bug #68442 [NEW]: can not restart fpm use signal -USR2

From: Date: Tue, 18 Nov 2014 04:05:59 +0000
Subject: Bug #68442 [NEW]: can not restart fpm use signal -USR2
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-188652@lists.php.net to get a copy of this message
From: alloyfang at sina dot com Operating system: CenetOS 6.5 x86_64 PHP version: 5.5.19 Package: FPM related Bug Type: Bug Bug description:can not restart fpm use signal -USR2 Description: ------------ use command kill -USR2 cat /export/home/web/php/var/run/php-fpm.pid to restart fpm, fpm stop and didn't start. php-5.5.19 restart log [18-Nov-2014 11:32:35] NOTICE: Reloading in progress ... [18-Nov-2014 11:32:35] NOTICE: reloading: execvp("/export/home/web/php/sbin/php-fpm", {"/export/home/web/php/sbin/php-fpm"}) [18-Nov-2014 11:32:35] NOTICE: using inherited socket fd=7, "L" [18-Nov-2014 11:32:35] NOTICE: using inherited socket fd=7, "L" [18-Nov-2014 11:32:35] ERROR: unable to bind listening socket for address '127.0.0.1:9000': Address already in use (98) [18-Nov-2014 11:32:35] ERROR: unable to bind listening socket for address '127.0.0.1:9000': Address already in use (98) [18-Nov-2014 11:32:35] ERROR: FPM initialization failed [18-Nov-2014 11:32:35] ERROR: FPM initialization failed It seem [fd=7, "L"] get some encode error.and it doesn't show the same when I try again. [18-Nov-2014 11:38:09] NOTICE: using inherited socket fd=7, "Ì" [18-Nov-2014 11:38:09] NOTICE: using inherited socket fd=7, "Ì" I test at php-5.5.7 and it works well php-5.5.7 restart log [18-Nov-2014 11:25:35] NOTICE: Reloading in progress ... [18-Nov-2014 11:25:35] NOTICE: reloading: execvp("/export/home/web/php/sbin/php-fpm", {"/export/home/web/php/sbin/php-fpm"}) [18-Nov-2014 11:25:35] NOTICE: using inherited socket fd=7, "127.0.0.1:9000" [18-Nov-2014 11:25:35] NOTICE: using inherited socket fd=7, "127.0.0.1:9000" [18-Nov-2014 11:25:35] NOTICE: fpm is running, pid 21790 [18-Nov-2014 11:25:35] NOTICE: ready to handle connections Expected result: ---------------- php-fpm should restart Actual result: -------------- php-fpm stop and didn't start -- Edit bug report at https://bugs.php.net/bug.php?id=68442&edit=1 -- Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=68442&r=trysnapshot54 Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=68442&r=trysnapshot55 Try a snapshot (trunk): https://bugs.php.net/fix.php?id=68442&r=trysnapshottrunk Fixed in SVN: https://bugs.php.net/fix.php?id=68442&r=fixed Fixed in release: https://bugs.php.net/fix.php?id=68442&r=alreadyfixed Need backtrace: https://bugs.php.net/fix.php?id=68442&r=needtrace Need Reproduce Script: https://bugs.php.net/fix.php?id=68442&r=needscript Try newer version: https://bugs.php.net/fix.php?id=68442&r=oldversion Not developer issue: https://bugs.php.net/fix.php?id=68442&r=support Expected behavior: https://bugs.php.net/fix.php?id=68442&r=notwrong Not enough info: https://bugs.php.net/fix.php?id=68442&r=notenoughinfo Submitted twice: https://bugs.php.net/fix.php?id=68442&r=submittedtwice register_globals: https://bugs.php.net/fix.php?id=68442&r=globals PHP 4 support discontinued: https://bugs.php.net/fix.php?id=68442&r=php4 Daylight Savings: https://bugs.php.net/fix.php?id=68442&r=dst IIS Stability: https://bugs.php.net/fix.php?id=68442&r=isapi Install GNU Sed: https://bugs.php.net/fix.php?id=68442&r=gnused Floating point limitations: https://bugs.php.net/fix.php?id=68442&r=float No Zend Extensions: https://bugs.php.net/fix.php?id=68442&r=nozend MySQL Configuration Error: https://bugs.php.net/fix.php?id=68442&r=mysqlcfg

« previous php.bugs (#188652) next »