Bug #68442 [Opn->Dup]: can not restart fpm use signal -USR2
| From: | remi@php.net | Date: | Tue, 18 Nov 2014 10:13:31 +0000 |
| Subject: | Bug #68442 [Opn->Dup]: can not restart fpm use signal -USR2 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-188656@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=68442&edit=1
ID: 68442
Updated by: remi@php.net
Reported by: alloyfang at sina dot com
Summary: can not restart fpm use signal -USR2
-Status: Open
+Status: Duplicate
Type: Bug
Package: FPM related
Operating System: CenetOS 6.5 x86_64
PHP Version: 5.5.19
-Assigned To:
+Assigned To: remi
Block user comment: N
Private report: N
New Comment:
Unit test added
http://git.php.net/?p=php-src.git;a=commitdiff;h=51394dff3f8d55fd40823e1841a97e631f4dfec5
Closing as duplicate of #68423
Previous Comments:
------------------------------------------------------------------------
[2014-11-18 08:09:47] remi@php.net
It seems to be related to other FPM bugs in 5.5.19 / 5.6.3
Can you please try this fix
http://git.php.net/?p=php-src.git;a=commitdiff;h=23db11976889c3600cf7853fe0fd687a1c9435e6
(tips: binary packages in remi repository for C6 includes these fix)
------------------------------------------------------------------------
[2014-11-18 04:05:57] alloyfang at sina dot com
Description:
------------
use command
kill -USR2
cat /export/home/web/php/var/run/php-fpm.pid
to restart fpm, fpm stop and didn't start.
php-5.5.19 restart log
[18-Nov-2014 11:32:35] NOTICE: Reloading in progress ...
[18-Nov-2014 11:32:35] NOTICE: reloading: execvp("/export/home/web/php/sbin/php-fpm",
{"/export/home/web/php/sbin/php-fpm"})
[18-Nov-2014 11:32:35] NOTICE: using inherited socket fd=7, "L"
[18-Nov-2014 11:32:35] NOTICE: using inherited socket fd=7, "L"
[18-Nov-2014 11:32:35] ERROR: unable to bind listening socket for address
'127.0.0.1:9000': Address already in use (98)
[18-Nov-2014 11:32:35] ERROR: unable to bind listening socket for address
'127.0.0.1:9000': Address already in use (98)
[18-Nov-2014 11:32:35] ERROR: FPM initialization failed
[18-Nov-2014 11:32:35] ERROR: FPM initialization failed
It seem [fd=7, "L"] get some encode error.and it doesn't show the same when I try
again.
[18-Nov-2014 11:38:09] NOTICE: using inherited socket fd=7, "Ã"
[18-Nov-2014 11:38:09] NOTICE: using inherited socket fd=7, "Ã"
I test at php-5.5.7 and it works well
php-5.5.7 restart log
[18-Nov-2014 11:25:35] NOTICE: Reloading in progress ...
[18-Nov-2014 11:25:35] NOTICE: reloading: execvp("/export/home/web/php/sbin/php-fpm",
{"/export/home/web/php/sbin/php-fpm"})
[18-Nov-2014 11:25:35] NOTICE: using inherited socket fd=7, "127.0.0.1:9000"
[18-Nov-2014 11:25:35] NOTICE: using inherited socket fd=7, "127.0.0.1:9000"
[18-Nov-2014 11:25:35] NOTICE: fpm is running, pid 21790
[18-Nov-2014 11:25:35] NOTICE: ready to handle connections
Expected result:
----------------
php-fpm should restart
Actual result:
--------------
php-fpm stop and didn't start
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=68442&edit=1