Bug #68945 [NEW]: Unknown admin values segfault pools

From: Date: Thu, 29 Jan 2015 14:58:11 +0000
Subject: Bug #68945 [NEW]: Unknown admin values segfault pools
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-190305@lists.php.net to get a copy of this message
From:             danack
Operating system: Centos 64bit
PHP version:      master-Git-2015-01-29 (Git)
Package:          FPM related
Bug Type:         Bug
Bug description:Unknown admin values segfault pools

Description:
------------
Trying to set the value for an 'unknown' ini setting through the FPM
config file for a pool causes the pool to segfault.  e.g. when APC isn't
loaded the presence of this line: 

php_admin_value[apc.shm_size] = "64M"

in a pool config file loaded automatically from /etc/php-fpm.d/

As PHP-FPM doesn't handle pools crashing on startup particularly well,
and doesn't give a visible error message, this can be seen more easily
by setting daemonize = no in /etc/php-fpm.conf

This does not crash on PHP5.6

Test script:
---------------
N/A

Expected result:
----------------
Unrecognized ini settings have no effect. 

Actual result:
--------------
PHP-FPM fails to start properly, and spams the log file with useless
information.

-- 
Edit bug report at https://bugs.php.net/bug.php?id=68945&edit=1
-- 
Try a snapshot (PHP 5.4):   https://bugs.php.net/fix.php?id=68945&r=trysnapshot54
Try a snapshot (PHP 5.5):   https://bugs.php.net/fix.php?id=68945&r=trysnapshot55
Try a snapshot (trunk):     https://bugs.php.net/fix.php?id=68945&r=trysnapshottrunk
Fixed in SVN:               https://bugs.php.net/fix.php?id=68945&r=fixed
Fixed in release:           https://bugs.php.net/fix.php?id=68945&r=alreadyfixed
Need backtrace:             https://bugs.php.net/fix.php?id=68945&r=needtrace
Need Reproduce Script:      https://bugs.php.net/fix.php?id=68945&r=needscript
Try newer version:          https://bugs.php.net/fix.php?id=68945&r=oldversion
Not developer issue:        https://bugs.php.net/fix.php?id=68945&r=support
Expected behavior:          https://bugs.php.net/fix.php?id=68945&r=notwrong
Not enough info:            https://bugs.php.net/fix.php?id=68945&r=notenoughinfo
Submitted twice:            https://bugs.php.net/fix.php?id=68945&r=submittedtwice
register_globals:           https://bugs.php.net/fix.php?id=68945&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=68945&r=php4
Daylight Savings:           https://bugs.php.net/fix.php?id=68945&r=dst
IIS Stability:              https://bugs.php.net/fix.php?id=68945&r=isapi
Install GNU Sed:            https://bugs.php.net/fix.php?id=68945&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=68945&r=float
No Zend Extensions:         https://bugs.php.net/fix.php?id=68945&r=nozend
MySQL Configuration Error:  https://bugs.php.net/fix.php?id=68945&r=mysqlcfg



Thread (2 messages)

« previous php.bugs (#190305) next »