Bug #68945 [Opn->Csd]: Unknown admin values segfault pools
Edit report at https://bugs.php.net/bug.php?id=68945&edit=1
ID: 68945
Updated by: laruence@php.net
Reported by: danack@php.net
Summary: Unknown admin values segfault pools
-Status: Open
+Status: Closed
Type: Bug
Package: FPM related
Operating System: Centos 64bit
PHP Version: master-Git-2015-01-29 (Git)
Block user comment: N
Private report: N
New Comment:
Automatic comment on behalf of laruence
Revision: http://git.php.net/?p=php-src.git;a=commit;h=88e13bda6af610a3d4acfdc2992d600002ebd287
Log: Fixed bug #68945 (Unknown admin values segfault pools)
Previous Comments:
------------------------------------------------------------------------
[2015-01-29 14:58:10] danack@php.net
Description:
------------
Trying to set the value for an 'unknown' ini setting through the FPM config file for a
pool causes the pool to segfault. e.g. when APC isn't loaded the presence of this line:
php_admin_value[apc.shm_size] = "64M"
in a pool config file loaded automatically from /etc/php-fpm.d/
As PHP-FPM doesn't handle pools crashing on startup particularly well, and doesn't give a
visible error message, this can be seen more easily by setting daemonize = no in
/etc/php-fpm.conf
This does not crash on PHP5.6
Test script:
---------------
N/A
Expected result:
----------------
Unrecognized ini settings have no effect.
Actual result:
--------------
PHP-FPM fails to start properly, and spams the log file with useless information.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=68945&edit=1
Thread (2 messages)