Edit report at https://bugs.php.net/bug.php?id=68698&edit=1
ID: 68698
Comment by: pegasus at vaultwiki dot org
Reported by: pegasus at vaultwiki dot org
Summary: Fatal error cannot redeclare [class not being
redeclared]
Status: No Feedback
Type: Bug
Package: Scripting Engine problem
Operating System: Centos 6 64-bit
PHP Version: 5.6Git-2014-12-30 (Git)
Block user comment: N
Private report: N
New Comment:
I am no longer experiencing this issue as of #d092cb6
Previous Comments:
------------------------------------------------------------------------
[2015-02-01 04:22:15] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
------------------------------------------------------------------------
[2015-01-23 19:54:45] aharvey@php.net
--disable-opcache should do it, or alternatively, you can just not load the extension in your
php.ini (since it's not built into PHP).
------------------------------------------------------------------------
[2015-01-22 21:25:33] pegasus at vaultwiki dot org
If you need my earlier question to be more explicit:
How do you prevent PHP from compiling the Zend Opcache extension?
If I start from a fresh build directory, ./buildconf, make clean, remove the old extension directory
at PREFIX/lib/php/extensions, comment out extension_dir from php.ini, and ./configure without
including --enable-opcache, the final "make install" just recreates the extension
directory WITH opcache.so in it.
Since it was implied by rasmus in another report that my issues might be caused by an incompatible
extension, I would like to completely rule out opcache.so, as it's my only extension, but I
can't seem to stop it from being created.
------------------------------------------------------------------------
[2015-01-19 06:25:37] pegasus at vaultwiki dot org
Recompiled with --enable-debug. The error does not occur with this configure option. Without this
option, the error persists.
After this recent compile, I looked in the extensions directory, and I'm now a bit confused.
Why opcache.so is compiled as an extension even if the --enable-opcache configure option is omitted?
This may have skewed previous tests as I always assumed opcache was turned off if I didn't opt
to compile it.
------------------------------------------------------------------------
[2015-01-18 17:49:50] pegasus at vaultwiki dot org
Is there a way that I can get a backtrace that will be useful to you when the fatal error occurs?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=68698
--
Edit this bug report at https://bugs.php.net/bug.php?id=68698&edit=1