Edit report at https://bugs.php.net/bug.php?id=68698&edit=1
ID: 68698
Comment by: info at interpost dot biz
Reported by: pegasus at vaultwiki dot org
Summary: Fatal error cannot redeclare [class not being
redeclared]
Status: No Feedback
Type: Bug
Package: Scripting Engine problem
Operating System: Centos 6 64-bit
PHP Version: 5.6Git-2014-12-30 (Git)
Block user comment: N
Private report: N
New Comment:
I have had this fatal error: Cannot redeclare class ... from PHP 5.6.12 through to and including
5.6.14 on Debian Jessie. It prevents horde (webmail) admin configuration pages from loading
properly (chrome gives an ERROR_EMPTY_RESPONSE error, and firefox states that the connection was
reset while the page wes loading) - same result no page. This error currently prevents a drupal 7.41
admin page from activating or or disabling modules. So this problem is still there. Is it a bug, or
a change in PHP's requirements that developers of other software need to re-code to make their
code compliant?
Previous Comments:
------------------------------------------------------------------------
[2015-03-21 13:28:49] pegasus at vaultwiki dot org
I am no longer experiencing this issue as of #d092cb6
------------------------------------------------------------------------
[2015-02-01 04:22:15] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
------------------------------------------------------------------------
[2015-01-23 19:54:45] aharvey@php.net
--disable-opcache should do it, or alternatively, you can just not load the extension in your
php.ini (since it's not built into PHP).
------------------------------------------------------------------------
[2015-01-22 21:25:33] pegasus at vaultwiki dot org
If you need my earlier question to be more explicit:
How do you prevent PHP from compiling the Zend Opcache extension?
If I start from a fresh build directory, ./buildconf, make clean, remove the old extension directory
at PREFIX/lib/php/extensions, comment out extension_dir from php.ini, and ./configure without
including --enable-opcache, the final "make install" just recreates the extension
directory WITH opcache.so in it.
Since it was implied by rasmus in another report that my issues might be caused by an incompatible
extension, I would like to completely rule out opcache.so, as it's my only extension, but I
can't seem to stop it from being created.
------------------------------------------------------------------------
[2015-01-19 06:25:37] pegasus at vaultwiki dot org
Recompiled with --enable-debug. The error does not occur with this configure option. Without this
option, the error persists.
After this recent compile, I looked in the extensions directory, and I'm now a bit confused.
Why opcache.so is compiled as an extension even if the --enable-opcache configure option is omitted?
This may have skewed previous tests as I always assumed opcache was turned off if I didn't opt
to compile it.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=68698
--
Edit this bug report at https://bugs.php.net/bug.php?id=68698&edit=1