#19422 [NEW]: apxs fails
| From: | m dot martinello at iol dot it | Date: | Sun, 15 Sep 2002 21:44:01 +0000 |
| Subject: | #19422 [NEW]: apxs fails | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-19413@lists.php.net to get a copy of this message | ||
From: m.martinello@iol.it
Operating system: Linux 2.4.18
PHP version: 4.2.3
PHP Bug Type: Compile Failure
Bug description: apxs fails
On "make install" the installation fails with the following error:
/usr/local/apache2/bin/apxs -i -a -n php4 libphp4.la
/usr/local/apache2/build/instdso.sh
SH_LIBTOOL='/usr/local/apache2/build/libtool' libphp4.la
/usr/local/apache2/modules
/usr/local/apache2/build/libtool --mode=install cp libphp4.la
/usr/local/apache2/modules/
cp .libs/libphp4.lai /usr/local/apache2/modules/libphp4.la
cp .libs/libphp4.a /usr/local/apache2/modules/libphp4.a
ranlib /usr/local/apache2/modules/libphp4.a
chmod 644 /usr/local/apache2/modules/libphp4.a
libtool: install: warning: remember to run `libtool --finish
/usr/local/php-4.2.3/libs'
mv: cannot move `/usr/local/apache2/modules/' to a subdirectory of itself,
`/usr/local/apache2/modules/libphp4.so'
chmod 755 /usr/local/apache2/modules/libphp4.so
chmod: getting attributes of `/usr/local/apache2/modules/libphp4.so': No
such file or directory
apxs:Error: Command failed with rc=65536
the "configure" line is:
./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql
--enable-track-vars --enable-calendar --enable-ctype --enable-gd-imgstrttf
--enable-gd-native-ttf --enable-magic-quotes --with-ftp --with-gettext
--with-imap=yes --with-ldap=yes --with-mcrypt --with-snmp --with-t1lib
--with-ttf --with-freetype-dir=yes --with-xml --with-swf=/usr/lib/libswf
--with-gd --with-imap-ssl --with-openssl
"configure" and "make" ends without any problem.
What can I do to solve this problem?
Thank you very much!
Bye
Mattia Martinello
--
Edit bug report at http://bugs.php.net/?id=19422&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=19422&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=19422&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=19422&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=19422&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=19422&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=19422&r=support
Expected behavior: http://bugs.php.net/fix.php?id=19422&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=19422&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=19422&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=19422&r=globals