#19422 [Bgs]: apxs fails
| From: | m dot martinello at iol dot it | Date: | Mon, 16 Sep 2002 18:45:34 +0000 |
| Subject: | #19422 [Bgs]: apxs fails | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-19485@lists.php.net to get a copy of this message | ||
ID: 19422
User updated by: m.martinello@iol.it
Reported By: m.martinello@iol.it
Status: Bogus
Bug Type: Apache2 related
Operating System: Linux 2.4.18
PHP Version: 4.2.3
New Comment:
I was installing PHP 4.2.3 on httpd 2.0.40.
I found the problem. I configured php without swf support and all
worked good.
The problem was the swf libs. Why?
Previous Comments:
------------------------------------------------------------------------
[2002-09-16 08:11:50] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php
If you can provide more information, feel free to add it
to this bug and change the status back to "Open".
Thank you for your interest in PHP.
------------------------------------------------------------------------
[2002-09-15 16:44:01] m.martinello@iol.it
On "make install" the installation fails with the following error:
/usr/local/apache2/bin/apxs -i -a -n php4 libphp4.la
/usr/local/apache2/build/instdso.sh
SH_LIBTOOL='/usr/local/apache2/build/libtool' libphp4.la
/usr/local/apache2/modules
/usr/local/apache2/build/libtool --mode=install cp libphp4.la
/usr/local/apache2/modules/
cp .libs/libphp4.lai /usr/local/apache2/modules/libphp4.la
cp .libs/libphp4.a /usr/local/apache2/modules/libphp4.a
ranlib /usr/local/apache2/modules/libphp4.a
chmod 644 /usr/local/apache2/modules/libphp4.a
libtool: install: warning: remember to run `libtool --finish
/usr/local/php-4.2.3/libs'
mv: cannot move `/usr/local/apache2/modules/' to a subdirectory of
itself, `/usr/local/apache2/modules/libphp4.so'
chmod 755 /usr/local/apache2/modules/libphp4.so
chmod: getting attributes of `/usr/local/apache2/modules/libphp4.so':
No such file or directory
apxs:Error: Command failed with rc=65536
the "configure" line is:
./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql
--enable-track-vars --enable-calendar --enable-ctype
--enable-gd-imgstrttf --enable-gd-native-ttf --enable-magic-quotes
--with-ftp --with-gettext --with-imap=yes --with-ldap=yes --with-mcrypt
--with-snmp --with-t1lib --with-ttf --with-freetype-dir=yes --with-xml
--with-swf=/usr/lib/libswf --with-gd --with-imap-ssl --with-openssl
"configure" and "make" ends without any problem.
What can I do to solve this problem?
Thank you very much!
Bye
Mattia Martinello
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19422&edit=1