#19423 [Opn]: Problem with extension_dir in PHP.ini

From: Date: Mon, 16 Sep 2002 07:39:04 +0000
Subject: #19423 [Opn]: Problem with extension_dir in PHP.ini
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-19423@lists.php.net to get a copy of this message
ID: 19423 Updated by: spic@php.net Reported By: cdfisher@swbell.net Status: Open -Bug Type: IIS related +Bug Type: *Web Server problem -Operating System: Win 2K Server +Operating System: Windows 9x/NT/ME/2000/XP PHP Version: 4.2.3 New Comment: This also occurs with MicroWeb-Server on Windows. So I reclassified it to WebServer-Problem. MicroWeb specific: Setting the extension_dir is not possible. Specifying a directory in the php.ini has no affect, although other settings can be configured fine... Microweb supports PHP only over CGI-Interface. Previous Comments: ------------------------------------------------------------------------ [2002-09-15 16:51:17] cdfisher@swbell.net I don't know what the problem with the extension_dir is on Win 2K. If there is anything assigned it returns an error with a / appended to the assignment directory (Setting extension_dir =c:\php\extensions returns c:\php\extensions/php_xslt.dll with the error text about not finding the file) and of course, the windows file system is not compatible, if that's the real problem. I got it to work as noted below. Here is what I had to do for IIS 5.x Win 2K with PHP 4.2.3 PHP.ini Directory in which the loadable extensions (modules) reside. extension_dir = Windows Extensions extension=php_xslt.dll Most everyone else who reported problems were using Apache on Windows with a diferent version of PHP, so that's why I think there might be a problem with the build for windows. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19423&edit=1

« previous php.bugs (#19423) next »