#19423 [Opn]: Problem with extension_dir in PHP.ini

From: Date: Mon, 16 Sep 2002 13:32:29 +0000
Subject: #19423 [Opn]: Problem with extension_dir in PHP.ini
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-19457@lists.php.net to get a copy of this message
ID: 19423 User updated by: cdfisher@swbell.net Reported By: cdfisher@swbell.net Status: Open Bug Type: *Web Server problem Operating System: Windows 9x/NT/ME/2000/XP PHP Version: 4.2.3 New Comment: Oh yeah, I forgot to add that all the pertinent files for this extension are in the %system% directory! Previous Comments: ------------------------------------------------------------------------ [2002-09-16 08:29:45] cdfisher@swbell.net To mficher: If you can give me some cookbook instructions on how to use this tool, then I would be glad to give it a try. It looks as though it needs a running process, but the error occurs when I start IIS. How can I accomplish what you need? ------------------------------------------------------------------------ [2002-09-16 03:24:32] mfischer@php.net Is there a chance to use the strace tool [1] to track what's going on/wrong here? This tool may help tracking down which directory/files are really accessed. [1] http://razor.bindview.com/tools/desc/strace_readme.html ------------------------------------------------------------------------ [2002-09-16 02:39:04] spic@php.net This also occurs with MicroWeb-Server on Windows. So I reclassified it to WebServer-Problem. MicroWeb specific: Setting the extension_dir is not possible. Specifying a directory in the php.ini has no affect, although other settings can be configured fine... Microweb supports PHP only over CGI-Interface. ------------------------------------------------------------------------ [2002-09-15 16:51:17] cdfisher@swbell.net I don't know what the problem with the extension_dir is on Win 2K. If there is anything assigned it returns an error with a / appended to the assignment directory (Setting extension_dir =c:\php\extensions returns c:\php\extensions/php_xslt.dll with the error text about not finding the file) and of course, the windows file system is not compatible, if that's the real problem. I got it to work as noted below. Here is what I had to do for IIS 5.x Win 2K with PHP 4.2.3 PHP.ini Directory in which the loadable extensions (modules) reside. extension_dir = Windows Extensions extension=php_xslt.dll Most everyone else who reported problems were using Apache on Windows with a diferent version of PHP, so that's why I think there might be a problem with the build for windows. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19423&edit=1

« previous php.bugs (#19457) next »