#19445 [NEW]: Memory problem of PHP in Win32 environment
| From: | 6800 at nyc dot odn dot ne dot jp | Date: | Tue, 17 Sep 2002 00:50:32 +0000 |
| Subject: | #19445 [NEW]: Memory problem of PHP in Win32 environment | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-19505@lists.php.net to get a copy of this message | ||
From: 6800@nyc.odn.ne.jp
Operating system: Windows2000Server
PHP version: 4.2.2
PHP Bug Type: Unknown/Other Function
Bug description: Memory problem of PHP in Win32 environment
Dear PHP Group,
I was using the machine that installed the memory of 256MB until July of
this year.
And in the end neighborhood in July, I increased the memory of the machine
to 1GB.
OS that was running normally until now from the instant, became unstable.
I thought this problem, that the beginning is the problem of OS.
I noticed that an OS error does not come out when do for a while and stop
Apache.
And I thought that the cause of this problem is in Apache.
However, my judgment may misï½.
It is because the OS error does not come out when the reason makes PHP the
CGI mode.
Only when PHP is an ISAPI mode namely, the OS error comes out.
This OS error is a violent thing and OS decreases in the case that the
initialization failure of the application frequently occurs and the
operation of OS be worst, become impossible.
I am inevitable, the problem is driving with the CGI mode without going
out now.
The details of my machine are as follows.
OS:Windows2000Server (Not using IIS at all)
MEMORY:1GBytes
HTTPD:Apache2.0.39(Win32) (Binary release)
PHP:4.2.2 (Binary release)
Others:mod_ssl/2.0.39 OpenSSL/0.9.6d mod_gzip/2.0.26.1a
Sincerely,
--
Edit bug report at http://bugs.php.net/?id=19445&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=19445&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=19445&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=19445&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=19445&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=19445&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=19445&r=support
Expected behavior: http://bugs.php.net/fix.php?id=19445&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=19445&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=19445&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=19445&r=globals