Bug #70474 [NEW]: errors shown in wrong accounts

From: Date: Fri, 11 Sep 2015 10:16:29 +0000
Subject: Bug #70474 [NEW]: errors shown in wrong accounts
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-195959@lists.php.net to get a copy of this message
From: hajo dot locke at gmx dot de Operating system: Ubuntu 14.04.3 LTS PHP version: 5.5.29 Package: Safe Mode/open_basedir Bug Type: Bug Bug description:errors shown in wrong accounts Description: ------------ Hello, we use PHP 5.5. as mod_php and open_basedir restrictions: /srv/htdocs/account1/:/tmp:/usr/bin:/srv/htdocs/account1:/bin:/usr/local/bin:/usr/share/php:/dev/urandom We host a lot of domains and most of domains use different homeaccounts. Sometimes it happens that user in account1 create by .htaccess individual error_log and accidently use wrong paths outside open_basedir but inside other valid accounts: php_flag log_errors on php_value error_log /srv/htdocs/account2/path/writeable.log Because its outside open_basedir the log is not used if errors occur on domains in account1. ("Unknown: open_basedir restriction in effect.....) But also it happens that this errormessages shows up in arbitrary errorlogs of other accounts. May be account3 is using an errorlog and sees errors about open_basedir restriction for account1 caused by wrong paths in .htaccess of account1 Why is PHP doing this? I think errors of this kind may written in central error_log if defined, but not individual error_logs of users. Is this configurable? -- Edit bug report at https://bugs.php.net/bug.php?id=70474&edit=1 -- Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=70474&r=trysnapshot54 Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=70474&r=trysnapshot55 Try a snapshot (trunk): https://bugs.php.net/fix.php?id=70474&r=trysnapshottrunk Fixed in SVN: https://bugs.php.net/fix.php?id=70474&r=fixed Fixed in release: https://bugs.php.net/fix.php?id=70474&r=alreadyfixed Need backtrace: https://bugs.php.net/fix.php?id=70474&r=needtrace Need Reproduce Script: https://bugs.php.net/fix.php?id=70474&r=needscript Try newer version: https://bugs.php.net/fix.php?id=70474&r=oldversion Not developer issue: https://bugs.php.net/fix.php?id=70474&r=support Expected behavior: https://bugs.php.net/fix.php?id=70474&r=notwrong Not enough info: https://bugs.php.net/fix.php?id=70474&r=notenoughinfo Submitted twice: https://bugs.php.net/fix.php?id=70474&r=submittedtwice register_globals: https://bugs.php.net/fix.php?id=70474&r=globals PHP 4 support discontinued: https://bugs.php.net/fix.php?id=70474&r=php4 Daylight Savings: https://bugs.php.net/fix.php?id=70474&r=dst IIS Stability: https://bugs.php.net/fix.php?id=70474&r=isapi Install GNU Sed: https://bugs.php.net/fix.php?id=70474&r=gnused Floating point limitations: https://bugs.php.net/fix.php?id=70474&r=float No Zend Extensions: https://bugs.php.net/fix.php?id=70474&r=nozend MySQL Configuration Error: https://bugs.php.net/fix.php?id=70474&r=mysqlcfg

« previous php.bugs (#195959) next »