Bug #70474 [Opn->Fbk]: errors shown in wrong accounts

From: Date: Thu, 20 May 2021 15:46:53 +0000
Subject: Bug #70474 [Opn->Fbk]: errors shown in wrong accounts
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-233923@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=70474&edit=1 ID: 70474 Updated by: cmb@php.net Reported by: hajo dot locke at gmx dot de Summary: errors shown in wrong accounts -Status: Open +Status: Feedback Type: Bug Package: Safe Mode/open_basedir Operating System: Ubuntu 14.04.3 LTS PHP Version: 5.5.29 -Assigned To: +Assigned To: cmb Block user comment: N Private report: N New Comment: Is this still an issue with any of the actively supported PHP versions[1]? Is OPcache enabled? If so, shared memory cache or file cache only? [1] <https://www.php.net/supported-versions.php> Previous Comments: ------------------------------------------------------------------------ [2015-09-11 10:16:26] hajo dot locke at gmx dot de Description: ------------ Hello, we use PHP 5.5. as mod_php and open_basedir restrictions: /srv/htdocs/account1/:/tmp:/usr/bin:/srv/htdocs/account1:/bin:/usr/local/bin:/usr/share/php:/dev/urandom We host a lot of domains and most of domains use different homeaccounts. Sometimes it happens that user in account1 create by .htaccess individual error_log and accidently use wrong paths outside open_basedir but inside other valid accounts: php_flag log_errors on php_value error_log /srv/htdocs/account2/path/writeable.log Because its outside open_basedir the log is not used if errors occur on domains in account1. ("Unknown: open_basedir restriction in effect.....) But also it happens that this errormessages shows up in arbitrary errorlogs of other accounts. May be account3 is using an errorlog and sees errors about open_basedir restriction for account1 caused by wrong paths in .htaccess of account1 Why is PHP doing this? I think errors of this kind may written in central error_log if defined, but not individual error_logs of users. Is this configurable? ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=70474&edit=1

« previous php.bugs (#233923) next »