Bug #70883 [NEW]: Production php.ini Example doesn't enable ext folder by default
From: james2432 at gmail dot com
Operating system: Windows Server 2012 R2
PHP version: 7.0.0RC6
Package: *Configuration Issues
Bug Type: Bug
Bug description:Production php.ini Example doesn't enable ext folder by default
Description:
------------
The example production php.ini has extension_dir commented out by
default.
This causes php to look in C:\php for extensions (despite being
installed else where, in this case: C:\php7\)(see apache log below)
PHP Warning: PHP Startup: Unable to load dynamic library
'C:\\php\\php_bz2.dll' - The specified module could not be found.\r\n in
Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'C:\\php\\php_curl.dll' - The specified module could not be found.\r\n
in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'C:\\php\\php_gd2.dll' - The specified module could not be found.\r\n in
Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'C:\\php\\php_ldap.dll' - The specified module could not be found.\r\n
in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'C:\\php\\php_exif.dll' - The specified module could not be found.\r\n
in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'C:\\php\\php_mysqli.dll' - The specified module could not be found.\r\n
in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'C:\\php\\php_openssl.dll' - The specified module could not be
found.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'C:\\php\\php_pdo_mysql.dll' - The specified module could not be
found.\r\n in Unknown on line 0
--
Edit bug report at https://bugs.php.net/bug.php?id=70883&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=70883&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=70883&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=70883&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=70883&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=70883&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=70883&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=70883&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=70883&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=70883&r=support
Expected behavior: https://bugs.php.net/fix.php?id=70883&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=70883&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=70883&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=70883&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=70883&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=70883&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=70883&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=70883&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=70883&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=70883&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=70883&r=mysqlcfg
Thread (2 messages)
- james2432 at gmail dot com