Bug #70883 [Opn->Nab]: Production php.ini Example doesn't enable ext folder by default
Edit report at https://bugs.php.net/bug.php?id=70883&edit=1
ID: 70883
Updated by: ab@php.net
Reported by: james2432 at gmail dot com
Summary: Production php.ini Example doesn't enable ext folder
by default
-Status: Open
+Status: Not a bug
Type: Bug
Package: *Configuration Issues
Operating System: Windows Server 2012 R2
PHP Version: 7.0.0RC6
Block user comment: N
Private report: N
New Comment:
Thanks for the report. Yes, you need to set the suitable paths and other options in your php.ini
file, otherwise the hardcoded default paths will be used. This is the exected behavior.
Thanks.
Previous Comments:
------------------------------------------------------------------------
[2015-11-09 16:31:06] james2432 at gmail dot com
Description:
------------
The example production php.ini has extension_dir commented out by default.
This causes php to look in C:\php for extensions (despite being installed else where, in this case:
C:\php7\)(see apache log below)
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\php\\php_bz2.dll' - The
specified module could not be found.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\php\\php_curl.dll' - The
specified module could not be found.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\php\\php_gd2.dll' - The
specified module could not be found.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\php\\php_ldap.dll' - The
specified module could not be found.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\php\\php_exif.dll' - The
specified module could not be found.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\php\\php_mysqli.dll' - The
specified module could not be found.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\php\\php_openssl.dll' - The
specified module could not be found.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\php\\php_pdo_mysql.dll' -
The specified module could not be found.\r\n in Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=70883&edit=1
Thread (2 messages)