Bug #71551 [Com]: scripts not run from php-cgi with mod_fcgid

From: Date: Tue, 09 Feb 2016 20:51:56 +0000
Subject: Bug #71551 [Com]: scripts not run from php-cgi with mod_fcgid
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-199140@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=71551&edit=1

 ID:                 71551
 Comment by:         ian at ocucom dot com
 Reported by:        ian at ocucom dot com
 Summary:            scripts not run from php-cgi with mod_fcgid
 Status:             Open
 Type:               Bug
 Package:            Apache2 related
 Operating System:   Windows 7
 PHP Version:        7.0.3
 Block user comment: N
 Private report:     N

 New Comment:

This also occurs using the Win32/x64 builds of Apache, mod_fcgid and php of the same point releases.


Previous Comments:
------------------------------------------------------------------------
[2016-02-09 01:41:19] ian at ocucom dot com

Also, thread-safe vs non-thread safe makes no difference. This error has occurred in every version
of 7.0 since RC2. It does not occur, using the same configs, with PHP 5.6.5.

------------------------------------------------------------------------
[2016-02-09 01:37:16] ian at ocucom dot com

Description:
------------
When using mod_fcgid with php-cgi to handle scripts, intermittently, php-cgi.exe will start, but the
script will not seem to load (no error_log() statements are logged, no output is sent, cpu usage is
0%) and after the fcgid timeouts, apache reports mod_fcgid: read timeout from pipe. 

This behavior is intermittent but seems to be related to new instances of php-cgi.

Apache: Apache Lounge 2.4.18 Win32 x86
Mod_fcgid: Apache Lounge mod_fcgid 2.3.9 Win32 x86
PHP: Windows.php.net PHP 7.0.3 php-cgi.exe



Expected result:
----------------
php runs a .php script

Actual result:
--------------
no content is returned, fcgid script timeout is reached, apache reports read timeout, serves 500
error. 

Happens more frequently if FcgidMaxRequestsPerProcess is set to 1. FcgidConnectTimeout values seem
to have no effect. It appears that mod_fcgid never "hooks up" to the php-cgi process. 


------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=71551&edit=1


Thread (12 messages)

« previous php.bugs (#199140) next »