Bug #71551 [Fbk->NoF]: scripts not run from php-cgi with mod_fcgid
| From: | php-bugs at lists dot php dot net | Date: | Sun, 28 Feb 2016 04:22:25 +0000 |
| Subject: | Bug #71551 [Fbk->NoF]: scripts not run from php-cgi with mod_fcgid | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-199509@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=71551&edit=1
ID: 71551
Updated by: php-bugs@lists.php.net
Reported by: ian at ocucom dot com
Summary: scripts not run from php-cgi with mod_fcgid
-Status: Feedback
+Status: No Feedback
Type: Bug
Package: Apache2 related
Operating System: Windows 7
PHP Version: 7.0.3
Private report: N
New Comment:
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
Previous Comments:
------------------------------------------------------------------------
[2016-02-17 21:53:22] ian at ocucom dot com
Here's a gist of the config files and a sample index.php to show the error:
https://gist.github.com/IanAtOcucom/0137d6c5f0cb70cdd51e
------------------------------------------------------------------------
[2016-02-16 20:31:02] ab@php.net
Please pastebin your Apache and PHP configs somewhere. If no one came to it, i'm going to check
when having a time frame. Will be useful otherwise anyway.
Thanks.
------------------------------------------------------------------------
[2016-02-09 20:51:55] ian at ocucom dot com
This also occurs using the Win32/x64 builds of Apache, mod_fcgid and php of the same point releases.
------------------------------------------------------------------------
[2016-02-09 01:41:19] ian at ocucom dot com
Also, thread-safe vs non-thread safe makes no difference. This error has occurred in every version
of 7.0 since RC2. It does not occur, using the same configs, with PHP 5.6.5.
------------------------------------------------------------------------
[2016-02-09 01:37:16] ian at ocucom dot com
Description:
------------
When using mod_fcgid with php-cgi to handle scripts, intermittently, php-cgi.exe will start, but the
script will not seem to load (no error_log() statements are logged, no output is sent, cpu usage is
0%) and after the fcgid timeouts, apache reports mod_fcgid: read timeout from pipe.
This behavior is intermittent but seems to be related to new instances of php-cgi.
Apache: Apache Lounge 2.4.18 Win32 x86
Mod_fcgid: Apache Lounge mod_fcgid 2.3.9 Win32 x86
PHP: Windows.php.net PHP 7.0.3 php-cgi.exe
Expected result:
----------------
php runs a .php script
Actual result:
--------------
no content is returned, fcgid script timeout is reached, apache reports read timeout, serves 500
error.
Happens more frequently if FcgidMaxRequestsPerProcess is set to 1. FcgidConnectTimeout values seem
to have no effect. It appears that mod_fcgid never "hooks up" to the php-cgi process.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=71551&edit=1