Bug #71189 [Com]: No space available for static Thread Local Storage

From: Date: Mon, 14 Mar 2016 21:37:51 +0000
Subject: Bug #71189 [Com]: No space available for static Thread Local Storage
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-199824@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=71189&edit=1

 ID:                 71189
 Comment by:         eu_gen at mail dot ru
 Reported by:        php at wesha dot name
 Summary:            No space available for static Thread Local Storage
 Status:             Open
 Type:               Bug
 Package:            Apache2 related
 Operating System:   FreeBSD-8.1
 PHP Version:        7.0.1
 Block user comment: N
 Private report:     N

 New Comment:

I've get the same error, Apache fails to start.
This error occurs regardless of the enabled modules/MPMs.
Have FreeBSD 10.2, Apache 2.4.18, PHP 7.0.4.


Previous Comments:
------------------------------------------------------------------------
[2015-12-22 03:17:11] php at wesha dot name

Description:
------------
When attempting to launch Apache 2.4.18 with PHP 7.0.1 module I recieve the following message:

Syntax error on line 153 of /usr/local/apache2/conf/httpd.conf: Cannot load modules/libphp7.so into
server: /usr/local/apache2/modules/libphp7.so: No space available for static Thread Local Storage

Line 153 is where the module loads:
LoadModule php7_module        modules/libphp7.so

PHP5 module loads just fine without any problems.

PHP7 configure string:

--with-mysql=[...censored...] --with-mysqli=mysqlnd --with-gd --with-apxs2=[...censored...]
--with-zlib --enable-gd-native-ttf --with-freetype-dir=[...censored...]
--with-jpeg-dir=[...censored...] --with-openssl --with-iconv --enable-mbstring --enable-sockets
--enable-pcntl --with-mcrypt --with-pdo-mysql --with-bz2 --enable-zip --with-curl
ac_cv_decimal_fp_supported=no --mandir=[...censored...] --without-pear




------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=71189&edit=1


Thread (10 messages)

« previous php.bugs (#199824) next »