#19502 [Bgs]: An automatic backup of the php.ini file?
| From: | nico_mittes at hotmail dot com | Date: | Sun, 22 Sep 2002 11:55:27 +0000 |
| Subject: | #19502 [Bgs]: An automatic backup of the php.ini file? | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-20036@lists.php.net to get a copy of this message | ||
ID: 19502
User updated by: nico_mittes@hotmail.com
Reported By: nico_mittes@hotmail.com
Status: Bogus
Bug Type: *Configuration Issues
Operating System: Windows NT 5.0 build 2195
PHP Version: 4.2.3
New Comment:
Hello,
This is my problem: For a few weeks now we're are using PHP and MySQL
and everything is working fine. But a week ago, everything turned
around
(I don't know a exact time): all our PHP/MySQL-sites gave errors. So,
I
immediately connected to our dedicated server (Windows NT) where I
searched for the php.ini file. The php.ini file was located in
C:\winnt\
(this is the important one of course), but it was also located in
c:\php\backup\ (I don't know the exact location, but I was sure in
some
backup-map in the PHP-directory. So, I searched php.ini (C:\winnt\)
for
the solution, I say that error_reporting was changed into
E_USER_NOTICE
(or E_USER_ERROR, I'm not sure). So, after this I changed it in E_ALL
&
~E_NOTICE, the standard value, and everything worked fine again.
But I'm now curious about the cause of this strange situation. Is it a
bug? It sure was not any of my collegues, as I am the only one that
connects with the dedicated server.
Looking forward to hear from you,
Nico Smit
Previous Comments:
------------------------------------------------------------------------
[2002-09-19 13:56:13] derick@php.net
PHP does not do this on its own, so the problem should lie elsewhere.
Not a PHP problem -> bogus.
Derick
------------------------------------------------------------------------
[2002-09-19 12:32:38] nico_mittes@hotmail.com
Hello,
This is my problem: For a few weeks now we're are using PHP and MySQL
and everything is working fine. But a week ago, everything turned
around (I don't know a exact time): all our PHP/MySQL-sites gave
errors. So, I immediately connected to our dedicated server (Windows
NT) where I searched for the php.ini file. The php.ini file was located
in C:\winnt\ (this is the important one of course), but it was also
located in c:\php\backup\ (I don't know the exact location, but I was
sure in some backup-map in the PHP-directory. So, I searched php.ini
(C:\winnt\) for the solution, I say that error_reporting was changed
into E_USER_NOTICE (or E_USER_ERROR, I'm not sure). So, after this I
changed it in E_ALL & ~E_NOTICE, the standard value, and everything
worked fine again.
But I'm now curious about the cause of this strange situation. Is it a
bug? I sure was not any of my collegues, as I am the only one that
connects with the dedicated server.
Looking forward to hear from you,
Nico Smit
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19502&edit=1