Bug #48809 [Com]: "virtual memory exhausted: Cannot allocate memory" with libmagic/apprentice.c

From: Date: Sun, 08 May 2016 20:07:07 +0000
Subject: Bug #48809 [Com]: "virtual memory exhausted: Cannot allocate memory" with libmagic/apprentice.c
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-200948@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=48809&edit=1

 ID:                 48809
 Comment by:         no-reply-thanks at fake-url dot example dot com
 Reported by:        ibboard at gmail dot com
 Summary:            "virtual memory exhausted: Cannot allocate memory"
                     with libmagic/apprentice.c
 Status:             Wont fix
 Type:               Bug
 Package:            Compile Failure
 Operating System:   CentOS 4
 PHP Version:        5.3.0
 Block user comment: N
 Private report:     N

 New Comment:

Like "info at fedushin dot ru" states, adding --disable-fileinfo to ./configure
"solves" the problem (I don't know if it has any negative effects though).


Previous Comments:
------------------------------------------------------------------------
[2015-12-22 15:07:57] noreplythanks at example dot fake dot com

I had this issue too, on Raspbian (Linux) on a Raspberry Pi.
It ran out of memory, even though no other applications were using much
memory. It just displays a chunk of text to do with installing and then
does nothing (whilst the memory it is using increases to "breaking point" as shown in Task
Manager), then something kicks in and kills it and it exits with an error:

"virtual memory exhausted: Cannot allocate memory
Makefile:742: recipe for target ext/fileinfo/libmagic/apprentice.lo failed
make:  *** [ext/fileinfo/libmagic/apprentice.lo] Error 1

------------------------------------------------------------------------
[2013-05-27 15:30:11] hawkdoom at mail dot ru

Ни хрена не помогло

------------------------------------------------------------------------
[2013-05-27 15:01:34] hawkdoom at mail dot ru

Проблема особенно силно
проявляется на выделенных
серверах с обрезанием
оперативы в тарифе, ща
попробую решение
предыдущего автора

------------------------------------------------------------------------
[2010-11-16 08:52:48] info at fedushin dot ru

Adding --disable-fileinfo to ./configure solves the problem.

------------------------------------------------------------------------
[2010-06-21 22:32:46] mackeul at gmail dot com

Ran into the same problem with GCC 3.4.5 on a "2.6.9-34.EL #1 Fri Feb 24 16:44:51 EST 2006 i686
i686 i386 GNU/Linux" machine 
with 256MB of memory.

------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

    https://bugs.php.net/bug.php?id=48809


--
Edit this bug report at https://bugs.php.net/bug.php?id=48809&edit=1


Thread (38 messages)

« previous php.bugs (#200948) next »