Bug #48809 [Com]: "virtual memory exhausted: Cannot allocate memory" with libmagic/apprentice.c

From: Date: Thu, 01 Jul 2021 00:45:40 +0000
Subject: Bug #48809 [Com]: "virtual memory exhausted: Cannot allocate memory" with libmagic/apprentice.c
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-234713@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=48809&edit=1 ID: 48809 Comment by: wahyuidm86 at gmail dot com Reported by: ibboard at gmail dot com Summary: "virtual memory exhausted: Cannot allocate memory" with libmagic/apprentice.c Status: Wont fix Type: Bug Package: Compile Failure Operating System: CentOS 4 PHP Version: 5.3.0 Block user comment: N Private report: N New Comment: I think this is among the most important info for me. And i am glad reading your article. But want to remark on few general things, The site style is wonderful, the articles is really great : D. Good job, cheers <a href= https://www.jualboiler.com/archives/3033/> Pusat Jual Thermal Oil Heater</a> Previous Comments: ------------------------------------------------------------------------ [2016-05-08 20:07:05] no-reply-thanks at fake-url dot example dot com Like "info at fedushin dot ru" states, adding --disable-fileinfo to ./configure "solves" the problem (I don't know if it has any negative effects though). ------------------------------------------------------------------------ [2015-12-22 15:07:57] noreplythanks at example dot fake dot com I had this issue too, on Raspbian (Linux) on a Raspberry Pi. It ran out of memory, even though no other applications were using much memory. It just displays a chunk of text to do with installing and then does nothing (whilst the memory it is using increases to "breaking point" as shown in Task Manager), then something kicks in and kills it and it exits with an error: "virtual memory exhausted: Cannot allocate memory Makefile:742: recipe for target ext/fileinfo/libmagic/apprentice.lo failed make: *** [ext/fileinfo/libmagic/apprentice.lo] Error 1 ------------------------------------------------------------------------ [2013-05-27 15:30:11] hawkdoom at mail dot ru Ни хрена не помогло ------------------------------------------------------------------------ [2013-05-27 15:01:34] hawkdoom at mail dot ru Проблема особенно силно проявляется на выделенных серверах с обрезанием оперативы в тарифе, ща попробую решение предыдущего автора ------------------------------------------------------------------------ [2010-11-16 08:52:48] info at fedushin dot ru Adding --disable-fileinfo to ./configure solves the problem. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=48809 -- Edit this bug report at https://bugs.php.net/bug.php?id=48809&edit=1

« previous php.bugs (#234713) next »