#19618 [Opn->Fbk]: Cannot load libphp4.so - Win32 error 5

From: Date: Thu, 26 Sep 2002 15:54:25 +0000
Subject: #19618 [Opn->Fbk]: Cannot load libphp4.so - Win32 error 5
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-20435@lists.php.net to get a copy of this message
ID: 19618 Updated by: sniper@php.net Reported By: bitcode@earthlink.net -Status: Open +Status: Feedback Bug Type: Apache2 related Operating System: Cygwin-XP PHP Version: 4.2.3 New Comment: Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip Previous Comments: ------------------------------------------------------------------------ [2002-09-26 10:37:11] bitcode@earthlink.net ty ------------------------------------------------------------------------ [2002-09-26 10:33:08] bitcode@earthlink.net Apache 2 was working swell... These were my PHP 4.2.3 compile commands: $./configure --with-mysql --with-apxs2=/usr/local/apache2/bin/apxs $make (worth noting at the end of make I see this warning... libtool: link: warning: undefined symbols not allowed in i686-pc-cygwin shared libraries make[1]: Leaving directory `/home/Administrator/php-4.2.3' Making all in pear make[1]: Entering directory `/home/Administrator/php-4.2.3/pear' make[1]: Leaving directory `/home/Administrator/php-4.2.3/pear' $ ) {is that the problem I wonder. Next.} $make install $cp php.ini-dist /usr/local/lib/php.ini (i also tried php.ini-recommended with same results) Then I changed the httpd.conf file.... appropriately... followed by... $/usr/local/apache2/bin/apachectl restart Syntax error on line 231 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp4.so into server: dlopen: Win32 error 5 System: Win xp pro - Cygwin - Apache 2 - php 4.2.3 ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19618&edit=1

« previous php.bugs (#20435) next »