#19618 [Fbk->NoF]: Cannot load libphp4.so - Win32 error 5

From: Date: Mon, 04 Nov 2002 07:00:06 +0000
Subject: #19618 [Fbk->NoF]: Cannot load libphp4.so - Win32 error 5
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-24018@lists.php.net to get a copy of this message
ID: 19618 Updated by: php-bugs@lists.php.net Reported By: bitcode@earthlink.net -Status: Feedback +Status: No Feedback Bug Type: Apache2 related Operating System: Cygwin-XP PHP Version: 4.2.3 New Comment: No feedback was provided for this bug for over 2 weeks, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". Previous Comments: ------------------------------------------------------------------------ [2002-10-19 17:00:22] iliaa@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ [2002-09-27 06:58:26] bitcode@earthlink.net correction to previous: $./configure --with-mysql --with-apxs=/usr/local/apache2/bin/apxs actually $./configure --with-mysql --with-apxs2=/usr/local/apache2/bin/apxs I forgot the 2 in the bug report, but not during the configure ------------------------------------------------------------------------ [2002-09-27 06:54:57] bitcode@earthlink.net Ok starting again with Apache2 & php4-200209261500 I recompiled Apache 2 again just to be safe.... Apache 2 working. $./configure --with-mysql --with-apxs=/usr/local/apache2/bin/apxs (this finishes without issue) $make (ends with) collect2: ld returned 1 exit status MAKE: *** [sapi/cli/php] Error 1 $make install (ends with) collect2: ld returned 1 exit status MAKE: *** [sapi/cli/php] Error 1 (Next the ini copy: The documentation states... Next you must copy php.ini-dist to the appropriate place (normally /usr/local/lib/php.ini) and edit it as necessary to set PHP options. I am uncertain of the appropriate place.... so I am copying it to the suggested place.) $cp php.ini-dist /usr/local/lib/php.ini I then add: LoadModule php4_module modules/libphp4.so AddType application/x-httpd-php .php ,to httpd.conf $/usr/local/apache2/bin/apachectl restart Syntax error on line 1028 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp4.so into server: dlopen: Win32 err or 5 ? ------------------------------------------------------------------------ [2002-09-26 10:54:25] sniper@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ [2002-09-26 10:37:11] bitcode@earthlink.net ty ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/19618 -- Edit this bug report at http://bugs.php.net/?id=19618&edit=1

« previous php.bugs (#24018) next »