Bug #74055 [Com]: Warning Internal error: wrong size calculation

From: Date: Wed, 29 Nov 2017 08:50:53 +0000
Subject: Bug #74055 [Com]: Warning Internal error: wrong size calculation
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-212791@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=74055&edit=1 ID: 74055 Comment by: tom60 at op dot pl Reported by: tom60 at op dot pl Summary: Warning Internal error: wrong size calculation Status: Open Type: Bug Package: opcache Operating System: Debian Jessie 64 bit PHP Version: 7.1.1 Block user comment: N Private report: N New Comment: It seems this issue was resolved for PHP 7.1.12 and 7.2.0RC4 - see: https://bugs.php.net/bug.php?id=75373 Previous Comments: ------------------------------------------------------------------------ [2017-09-04 09:30:34] spam2 at rhsoft dot net and it don't happen with every file, otherwise we would have a serious problem on the first production server running with 7.1 where one developer needs to live-debug his application with the customer changes to my "global_mysql_ext.inc" seems to trigger it always and until now i am not sure if after the mesagew the problem is gone or not because i prefer i service restart to find out the impact if not doing so ------------------------------------------------------------------------ [2017-09-04 09:25:46] spam2 at rhsoft dot net this happens here too and what i can tell you is that it somehow is related to update cached files, last night i made a small change to "global_mysql_ext.inc" and voila that error happended again while never seen that with 7.0.x or 5.x Mon Sep 4 00:39:07 2017 (13087): Warning Internal error: wrong size calculation: /phpincludes/global_mysql_ext.inc.php start=0x00007f0df18a40c0, end=0x00007f0df18c83e0, real=0x00007f0df18c83c0 ------------------------------------------------------------------------ [2017-03-30 14:24:27] tom60 at op dot pl The issue happens sporadically 3-10 times a day on our server, even after upgrading to PHP 7.1.3. ------------------------------------------------------------------------ [2017-03-11 12:40:06] nikic@php.net Is this error reproducible reliably or does it happen sporadically? I was not able to reproduce the issue when running the provided files standalone. ------------------------------------------------------------------------ [2017-03-11 11:47:51] paul at totallytechy dot com Same as below, since upgrading from 7.0.x opcache: Sat Mar 11 11:46:45 2017 (3200): Warning Internal error: wrong size calculation: /var/www/redacted/includes/common.inc start=0x00007f7d55c9d440, end=0x00007f7d55d419c0, real=0x00007f7d55d419a0 64bit Amazon Linux 2016.09 v2.5.1 PHP 7.1.2-4+deb.sury.org~trusty+1 (cli) (built: Mar 2 2017 13:23:06) ( NTS ) [opcache] opcache.enable=1 opcache.dups_fix=1 opcache.enable_cli=1 opcache.memory_consumption=128 opcache.use_cwd=1 opcache.blacklist_filename=/etc/php/7.1/opcache-blacklist.txt opcache.error_log=/var/log/php/opcache.err.log opcache.log_verbosity_level=2 opcache.interned_strings_buffer=8 opcache.max_accelerated_files=10000 opcache.revalidate_freq=0 ;opcache.revalidate_freq=5 opcache.fast_shutdown=1 opcache.validate_timestamps=1 opcache.revalidate_path=1 ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=74055 -- Edit this bug report at https://bugs.php.net/bug.php?id=74055&edit=1

« previous php.bugs (#212791) next »