Bug #74055 [Opn->Dup]: Warning Internal error: wrong size calculation
Edit report at https://bugs.php.net/bug.php?id=74055&edit=1
ID: 74055
Updated by: nikic@php.net
Reported by: tom60 at op dot pl
Summary: Warning Internal error: wrong size calculation
-Status: Open
+Status: Duplicate
Type: Bug
Package: opcache
Operating System: Debian Jessie 64 bit
PHP Version: 7.1.1
Block user comment: N
Private report: N
New Comment:
Closing this as a duplicate of bug #75373, which is now fixed.
Previous Comments:
------------------------------------------------------------------------
[2017-11-29 08:50:52] tom60 at op dot pl
It seems this issue was resolved for PHP 7.1.12 and 7.2.0RC4 - see: https://bugs.php.net/bug.php?id=75373
------------------------------------------------------------------------
[2017-09-04 09:30:34] spam2 at rhsoft dot net
and it don't happen with every file, otherwise we would have a serious problem on the first
production server running with 7.1 where one developer needs to live-debug his application with the
customer
changes to my "global_mysql_ext.inc" seems to trigger it always and until now i am not
sure if after the mesagew the problem is gone or not because i prefer i service restart to find out
the impact if not doing so
------------------------------------------------------------------------
[2017-09-04 09:25:46] spam2 at rhsoft dot net
this happens here too and what i can tell you is that it somehow is related to update cached files,
last night i made a small change to "global_mysql_ext.inc" and voila that error happended
again while never seen that with 7.0.x or 5.x
Mon Sep 4 00:39:07 2017 (13087): Warning Internal error: wrong size calculation:
/phpincludes/global_mysql_ext.inc.php start=0x00007f0df18a40c0, end=0x00007f0df18c83e0,
real=0x00007f0df18c83c0
------------------------------------------------------------------------
[2017-03-30 14:24:27] tom60 at op dot pl
The issue happens sporadically 3-10 times a day on our server, even after upgrading to PHP 7.1.3.
------------------------------------------------------------------------
[2017-03-11 12:40:06] nikic@php.net
Is this error reproducible reliably or does it happen sporadically? I was not able to reproduce the
issue when running the provided files standalone.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=74055
--
Edit this bug report at https://bugs.php.net/bug.php?id=74055&edit=1
Thread (8 messages)