Bug #75858 [NEW]: Enabling opcache in PHP v7.1 returns MS-SQL driver errors

From: Date: Mon, 22 Jan 2018 22:49:21 +0000
Subject: Bug #75858 [NEW]: Enabling opcache in PHP v7.1 returns MS-SQL driver errors
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-213668@lists.php.net to get a copy of this message
From: bahead at gmail dot com Operating system: Windows Server 2012 PHP version: 7.1.13 Package: opcache Bug Type: Bug Bug description:Enabling opcache in PHP v7.1 returns MS-SQL driver errors Description: ------------ MS-SQL driver version or file name: php_pdo_sqlsrv_71_nts.dll - File version 4.1.8.9607 (32 bit) SQL Server version: Microsoft SQL Server Express (64-bit) - 13.0.4206.0 Client operating system: Windows Server 2012 64-bit PHP version: 7.1 Microsoft ODBC Driver version: 13 I'm upgrading an existing website from PHP v5.6 to v7.1. The only changes are the PHP version and the version of the MS-SQL PHP drivers. Everything works as expected (as per previous site), except when I enable Zend opcache in php.ini. When I enable it, the site returns one of two error messages: SQLSTATE[08001]: [Microsoft][ODBC Driver 13 for SQL Server]SQL Server Network Interfaces: Not enough storage is available to process this command. 1 or occasionally Fatal error: No ODBC error was found The existing PHP v5.6 site has opcache enabled using MS-SQL drivers and does not return errors. Changing opcache settings in PHP v7.1 has no effect on the errors. If I disable Zend opcache, the errors disappear. They only present themselves when opcache is enabled. Test script: --------------- try { $conn = new PDO('sqlsrv:server='.MSSQL_SERVER.'; Database='.MSSQL_DB, MSSQL_USER, MSSQL_PWD); $conn->setAttribute( PDO::ATTR_ERRMODE, PDO::ERRMODE_WARNING ); } catch(Exception $e) { die( print_r( $e->getMessage() ) ); } -- Edit bug report at https://bugs.php.net/bug.php?id=75858&edit=1 -- Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=75858&r=trysnapshot54 Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=75858&r=trysnapshot55 Try a snapshot (trunk): https://bugs.php.net/fix.php?id=75858&r=trysnapshottrunk Fixed in SVN: https://bugs.php.net/fix.php?id=75858&r=fixed Fixed in release: https://bugs.php.net/fix.php?id=75858&r=alreadyfixed Need backtrace: https://bugs.php.net/fix.php?id=75858&r=needtrace Need Reproduce Script: https://bugs.php.net/fix.php?id=75858&r=needscript Try newer version: https://bugs.php.net/fix.php?id=75858&r=oldversion Not developer issue: https://bugs.php.net/fix.php?id=75858&r=support Expected behavior: https://bugs.php.net/fix.php?id=75858&r=notwrong Not enough info: https://bugs.php.net/fix.php?id=75858&r=notenoughinfo Submitted twice: https://bugs.php.net/fix.php?id=75858&r=submittedtwice register_globals: https://bugs.php.net/fix.php?id=75858&r=globals PHP 4 support discontinued: https://bugs.php.net/fix.php?id=75858&r=php4 Daylight Savings: https://bugs.php.net/fix.php?id=75858&r=dst IIS Stability: https://bugs.php.net/fix.php?id=75858&r=isapi Install GNU Sed: https://bugs.php.net/fix.php?id=75858&r=gnused Floating point limitations: https://bugs.php.net/fix.php?id=75858&r=float No Zend Extensions: https://bugs.php.net/fix.php?id=75858&r=nozend MySQL Configuration Error: https://bugs.php.net/fix.php?id=75858&r=mysqlcfg

« previous php.bugs (#213668) next »