Bug #75858 [Opn->Fbk]: Enabling opcache in PHP v7.1 returns MS-SQL driver errors

From: Date: Fri, 13 Nov 2020 15:59:41 +0000
Subject: Bug #75858 [Opn->Fbk]: Enabling opcache in PHP v7.1 returns MS-SQL driver errors
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-230338@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=75858&edit=1 ID: 75858 Updated by: cmb@php.net Reported by: bahead at gmail dot com Summary: Enabling opcache in PHP v7.1 returns MS-SQL driver errors -Status: Open +Status: Feedback Type: Bug Package: opcache Operating System: Windows Server 2012 PHP Version: 7.1.13 -Assigned To: +Assigned To: cmb Block user comment: N Private report: N New Comment: Is that still an issue with any of the actively supported PHP versions[1], and the latest stable PDO_SQLSRV (5.8.1)? [1] <https://www.php.net/supported-versions.php> Previous Comments: ------------------------------------------------------------------------ [2018-01-22 22:49:20] bahead at gmail dot com Description: ------------ MS-SQL driver version or file name: php_pdo_sqlsrv_71_nts.dll - File version 4.1.8.9607 (32 bit) SQL Server version: Microsoft SQL Server Express (64-bit) - 13.0.4206.0 Client operating system: Windows Server 2012 64-bit PHP version: 7.1 Microsoft ODBC Driver version: 13 I'm upgrading an existing website from PHP v5.6 to v7.1. The only changes are the PHP version and the version of the MS-SQL PHP drivers. Everything works as expected (as per previous site), except when I enable Zend opcache in php.ini. When I enable it, the site returns one of two error messages: SQLSTATE[08001]: [Microsoft][ODBC Driver 13 for SQL Server]SQL Server Network Interfaces: Not enough storage is available to process this command. 1 or occasionally Fatal error: No ODBC error was found The existing PHP v5.6 site has opcache enabled using MS-SQL drivers and does not return errors. Changing opcache settings in PHP v7.1 has no effect on the errors. If I disable Zend opcache, the errors disappear. They only present themselves when opcache is enabled. Test script: --------------- try { $conn = new PDO('sqlsrv:server='.MSSQL_SERVER.'; Database='.MSSQL_DB, MSSQL_USER, MSSQL_PWD); $conn->setAttribute( PDO::ATTR_ERRMODE, PDO::ERRMODE_WARNING ); } catch(Exception $e) { die( print_r( $e->getMessage() ) ); } ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=75858&edit=1

« previous php.bugs (#230338) next »