Bug #76271 [NEW]: WAMPSERVER 3.1.3 32 bit, PHP 7.2.4 Oracle Client 11g issue

From: Date: Wed, 25 Apr 2018 18:17:09 +0000
Subject: Bug #76271 [NEW]: WAMPSERVER 3.1.3 32 bit, PHP 7.2.4 Oracle Client 11g issue
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-214896@lists.php.net to get a copy of this message
From:             ukpatel890 at gmail dot com
Operating system: window 7 32 bit
PHP version:      7.2.4
Package:          Oracle related
Bug Type:         Bug
Bug description:WAMPSERVER 3.1.3 32 bit, PHP 7.2.4 Oracle Client 11g issue

Description:
------------
WAMPSERVER 3.1.3 32 bit, PHP 7.2.4 Oracle Client 11g issue

I have installed Wampserver 3.1.3,32 bit on Windows 7 machine(32 bit).
Wamp server has been installed correctly, getting a green icon on
startup.

I have installed Oracle 32 client 11g on Windows machine and system
environment variable path has been set
c:\app\USER\product\11.2.0\client_1\bin;, where OCI.dll resides.

For work with oracle quries, I had enabled extension=php_oci8_11g in my
php.ini file. Have verified, that php_oci8_11g.dll exists at
C:\wamp\bin\php\php7.2.4\ext. And also verified, that extension_dir has
been set to extension_dir ="c:/wamp/bin/php/php7.2.4/ext/" in my
php.ini.

Whenever I start Wamp server, the icon changes to green, but errors are
generated in PHP_ERROR log file

[24-Apr-2018 18:10:07 UTC] PHP Warning: PHP Startup: Unable to load
dynamic library 'oci8_11g' (tried: c:/wamp/bin/php/php7.2.4/ext/oci8_11g
(The specified module could not be found.),
c:/wamp/bin/php/php7.2.4/ext/php_oci8_11g.dll (The specified module
could not be found.)) in Unknown on line 0

Because of provided error my Oracle queries are not working. 


-- 
Edit bug report at https://bugs.php.net/bug.php?id=76271&edit=1
-- 
Try a snapshot (PHP 5.4):   https://bugs.php.net/fix.php?id=76271&r=trysnapshot54
Try a snapshot (PHP 5.5):   https://bugs.php.net/fix.php?id=76271&r=trysnapshot55
Try a snapshot (trunk):     https://bugs.php.net/fix.php?id=76271&r=trysnapshottrunk
Fixed in SVN:               https://bugs.php.net/fix.php?id=76271&r=fixed
Fixed in release:           https://bugs.php.net/fix.php?id=76271&r=alreadyfixed
Need backtrace:             https://bugs.php.net/fix.php?id=76271&r=needtrace
Need Reproduce Script:      https://bugs.php.net/fix.php?id=76271&r=needscript
Try newer version:          https://bugs.php.net/fix.php?id=76271&r=oldversion
Not developer issue:        https://bugs.php.net/fix.php?id=76271&r=support
Expected behavior:          https://bugs.php.net/fix.php?id=76271&r=notwrong
Not enough info:            https://bugs.php.net/fix.php?id=76271&r=notenoughinfo
Submitted twice:            https://bugs.php.net/fix.php?id=76271&r=submittedtwice
register_globals:           https://bugs.php.net/fix.php?id=76271&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=76271&r=php4
Daylight Savings:           https://bugs.php.net/fix.php?id=76271&r=dst
IIS Stability:              https://bugs.php.net/fix.php?id=76271&r=isapi
Install GNU Sed:            https://bugs.php.net/fix.php?id=76271&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=76271&r=float
No Zend Extensions:         https://bugs.php.net/fix.php?id=76271&r=nozend
MySQL Configuration Error:  https://bugs.php.net/fix.php?id=76271&r=mysqlcfg



Thread (13 messages)

« previous php.bugs (#214896) next »