Bug #76271 [Fbk]: WAMPSERVER 3.1.3 32 bit, PHP 7.2.4 Oracle Client 11g issue

From: Date: Thu, 26 Apr 2018 10:28:02 +0000
Subject: Bug #76271 [Fbk]: WAMPSERVER 3.1.3 32 bit, PHP 7.2.4 Oracle Client 11g issue
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-214903@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=76271&edit=1

 ID:                 76271
 Updated by:         requinix@php.net
 Reported by:        ukpatel890 at gmail dot com
 Summary:            WAMPSERVER 3.1.3 32 bit, PHP 7.2.4 Oracle Client 11g
                     issue
 Status:             Feedback
 Type:               Bug
 Package:            OCI8 related
 Operating System:   window 7 32 bit
 PHP Version:        7.2.4
 Block user comment: N
 Private report:     N

 New Comment:

The only one I see besides php7.dll is oci.dll. Since you did the first part about making sure the
oci8 file is present, do the rest of what I said about checking that files are in the path and that
PHP reports the path you think it has.


Previous Comments:
------------------------------------------------------------------------
[2018-04-26 07:47:52] ukpatel890 at gmail dot com

I have verified, php_oci8_11g.dll file is their at c:/wamp/bin/php/php7.2.4/ext/
What are dependent files ?

------------------------------------------------------------------------
[2018-04-26 01:05:49] requinix@php.net

Either the file is not there or one of its dependencies is missing/not in the search path. Double
check everything.
Also use PHP to check that your PATH environment variable is what you think it is.

------------------------------------------------------------------------
[2018-04-25 18:17:07] ukpatel890 at gmail dot com

Description:
------------
WAMPSERVER 3.1.3 32 bit, PHP 7.2.4 Oracle Client 11g issue

I have installed Wampserver 3.1.3,32 bit on Windows 7 machine(32 bit). Wamp server has been
installed correctly, getting a green icon on startup.

I have installed Oracle 32 client 11g on Windows machine and system environment variable path has
been set c:\app\USER\product\11.2.0\client_1\bin;, where OCI.dll resides.

For work with oracle quries, I had enabled extension=php_oci8_11g in my php.ini file. Have verified,
that php_oci8_11g.dll exists at C:\wamp\bin\php\php7.2.4\ext. And also verified, that extension_dir
has been set to extension_dir ="c:/wamp/bin/php/php7.2.4/ext/" in my php.ini.

Whenever I start Wamp server, the icon changes to green, but errors are generated in PHP_ERROR log
file

[24-Apr-2018 18:10:07 UTC] PHP Warning: PHP Startup: Unable to load dynamic library
'oci8_11g' (tried: c:/wamp/bin/php/php7.2.4/ext/oci8_11g (The specified module could not
be found.), c:/wamp/bin/php/php7.2.4/ext/php_oci8_11g.dll (The specified module could not be
found.)) in Unknown on line 0

Because of provided error my Oracle queries are not working. 



------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=76271&edit=1


Thread (13 messages)

« previous php.bugs (#214903) next »