Bug #76656 [NEW]: Unable to load dynamic library oci8

From: Date: Mon, 23 Jul 2018 08:06:18 +0000
Subject: Bug #76656 [NEW]: Unable to load dynamic library oci8
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-216404@lists.php.net to get a copy of this message
From:             l dot straka at t-systems dot com
Operating system: AIX IBM 7.1
PHP version:      5.6.37
Package:          OCI8 related
Bug Type:         Bug
Bug description:Unable to load dynamic library oci8

Description:
------------
I have PHP 5.6.32 , Apache/2.4.29 (Unix), instant client 12_1 and OCI8
oci8-2.0.12. 

I used this manual http://php.net/manual/en/oci8.installation.php
and
steps: "For a manual install when the pecl command is not available,
download the PECL OCI8 package"

After .configure and make and make install , I start apache and in error
log I see this : 

PHP Warning:  PHP Startup: Unable to load dynamic library
'/opt/freeware/lib/php/modules/oci8.so' - rtld: 0712-001 Symbol
compiler_globals was referenced\n      from module
/opt/freeware/lib/php/modules/oci8.so(), but a runtime definition\n\t   
of the symbol was not found.\nrtld: 0712-001 Symbol executor_globals was
referenced\n      from module /opt/freeware/lib/php/modules/oci8.so(),
but a runtime definition\n\t    of the symbol was not found.\nrtld:
0712-001 Symbol core_globals was referenced\n      from module
/opt/freeware/lib/php/modules/oci8.so(), but a runtime definition\n\t   
of the symbol was not found. in Unknown on line 0
[Mon Jul 23 09:45:22.415279 2018] [mpm_prefork:notice] [pid 28835870]
AH00163: Apache/2.4.29 (Unix) PHP/5.6.32 configured -- resuming normal
operations
[Mon Jul 23 09:45:22.415463 2018] [mpm_prefork:info] [pid 28835870]
AH00164: Server built: Dec 18 2017 08:44:23
[Mon Jul 23 09:45:22.415483 2018] [core:notice] [pid 28835870] AH00094:
Command line: '/opt/freeware/sbin/httpd'
[Mon Jul 23 09:45:22.415493 2018] [core:debug] [pid 28835870]
log.c(1567): AH02639: Using SO_REUSEPORT: no (1)
[Mon Jul 23 09:45:22.415499 2018] [mpm_prefork:debug] [pid 28835870]
prefork.c(921): AH00165: Accept mutex: none (default: sysvsem)

I have exported all needed Oracle environment variables in apache
envvars.




-- 
Edit bug report at https://bugs.php.net/bug.php?id=76656&edit=1
-- 
Try a snapshot (PHP 5.4):   https://bugs.php.net/fix.php?id=76656&r=trysnapshot54
Try a snapshot (PHP 5.5):   https://bugs.php.net/fix.php?id=76656&r=trysnapshot55
Try a snapshot (trunk):     https://bugs.php.net/fix.php?id=76656&r=trysnapshottrunk
Fixed in SVN:               https://bugs.php.net/fix.php?id=76656&r=fixed
Fixed in release:           https://bugs.php.net/fix.php?id=76656&r=alreadyfixed
Need backtrace:             https://bugs.php.net/fix.php?id=76656&r=needtrace
Need Reproduce Script:      https://bugs.php.net/fix.php?id=76656&r=needscript
Try newer version:          https://bugs.php.net/fix.php?id=76656&r=oldversion
Not developer issue:        https://bugs.php.net/fix.php?id=76656&r=support
Expected behavior:          https://bugs.php.net/fix.php?id=76656&r=notwrong
Not enough info:            https://bugs.php.net/fix.php?id=76656&r=notenoughinfo
Submitted twice:            https://bugs.php.net/fix.php?id=76656&r=submittedtwice
register_globals:           https://bugs.php.net/fix.php?id=76656&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=76656&r=php4
Daylight Savings:           https://bugs.php.net/fix.php?id=76656&r=dst
IIS Stability:              https://bugs.php.net/fix.php?id=76656&r=isapi
Install GNU Sed:            https://bugs.php.net/fix.php?id=76656&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=76656&r=float
No Zend Extensions:         https://bugs.php.net/fix.php?id=76656&r=nozend
MySQL Configuration Error:  https://bugs.php.net/fix.php?id=76656&r=mysqlcfg



Thread (12 messages)

« previous php.bugs (#216404) next »