Bug #76656 [Fbk]: Unable to load dynamic library oci8

From: Date: Mon, 23 Jul 2018 12:49:34 +0000
Subject: Bug #76656 [Fbk]: Unable to load dynamic library oci8
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-216407@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=76656&edit=1

 ID:                 76656
 Updated by:         cmb@php.net
 Reported by:        l dot straka at t-systems dot com
 Summary:            Unable to load dynamic library oci8
 Status:             Feedback
 Type:               Bug
 Package:            OCI8 related
 Operating System:   AIX IBM 7.1
 PHP Version:        5.6.37
 Assigned To:        cmb
 Block user comment: N
 Private report:     N

 New Comment:

phpize && ./configure … && make


Previous Comments:
------------------------------------------------------------------------
[2018-07-23 12:25:32] l dot strala at t-systems dot com

I configured the oci8.so now with 
./configure .......................

-same problem

Also tried to install with pecl/pear. Same result, same error.

How can i force to be "thread safe" oci8 extension?

------------------------------------------------------------------------
[2018-07-23 09:50:14] cmb@php.net

Seems you're trying to load a non thread-safe extension into a
thread-safe PHP.  See the manual on how to properly build:
<http://php.net/manual/en/install.pecl.phpize.php>
<http://php.net/manual/en/install.pecl.static.php>

------------------------------------------------------------------------
[2018-07-23 08:06:18] l dot straka at t-systems dot com

Description:
------------
I have PHP 5.6.32 , Apache/2.4.29 (Unix), instant client 12_1 and OCI8 oci8-2.0.12. 

I used this manual http://php.net/manual/en/oci8.installation.php
and steps: "For a manual install when the pecl command is not available, download the PECL OCI8
package"

After .configure and make and make install , I start apache and in error log I see this : 

PHP Warning:  PHP Startup: Unable to load dynamic library
'/opt/freeware/lib/php/modules/oci8.so' - rtld: 0712-001 Symbol compiler_globals was
referenced\n      from module /opt/freeware/lib/php/modules/oci8.so(), but a runtime definition\n\t 
  of the symbol was not found.\nrtld: 0712-001 Symbol executor_globals was referenced\n      from
module /opt/freeware/lib/php/modules/oci8.so(), but a runtime definition\n\t    of the symbol was
not found.\nrtld: 0712-001 Symbol core_globals was referenced\n      from module
/opt/freeware/lib/php/modules/oci8.so(), but a runtime definition\n\t    of the symbol was not
found. in Unknown on line 0
[Mon Jul 23 09:45:22.415279 2018] [mpm_prefork:notice] [pid 28835870] AH00163: Apache/2.4.29 (Unix)
PHP/5.6.32 configured -- resuming normal operations
[Mon Jul 23 09:45:22.415463 2018] [mpm_prefork:info] [pid 28835870] AH00164: Server built: Dec 18
2017 08:44:23
[Mon Jul 23 09:45:22.415483 2018] [core:notice] [pid 28835870] AH00094: Command line:
'/opt/freeware/sbin/httpd'
[Mon Jul 23 09:45:22.415493 2018] [core:debug] [pid 28835870] log.c(1567): AH02639: Using
SO_REUSEPORT: no (1)
[Mon Jul 23 09:45:22.415499 2018] [mpm_prefork:debug] [pid 28835870] prefork.c(921): AH00165: Accept
mutex: none (default: sysvsem)

I have exported all needed Oracle environment variables in apache envvars.





------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=76656&edit=1


Thread (12 messages)

« previous php.bugs (#216407) next »