Bug #76835 [NEW]: FPM stuck at getrandom()
| From: | olafvdspek at gmail dot com | Date: | Sun, 02 Sep 2018 07:25:59 +0000 |
| Subject: | Bug #76835 [NEW]: FPM stuck at getrandom() | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-216845@lists.php.net to get a copy of this message | ||
From: olafvdspek at gmail dot com
Operating system: Debian
PHP version: 7.2.9
Package: FPM related
Bug Type: Bug
Bug description:FPM stuck at getrandom()
Description:
------------
Debian is running in a VM.
At boot, it tries to start php-fpm via systemd. After a minute or so, it
times out as php-fpm seems stuck at a getrandom() call.
Actual result:
--------------
# strace -p 383
strace: Process 383 attached
getrandom(0x7ffd606d51f0, 16, 0) = ? ERESTARTSYS (To be restarted
if SA_RESTART is set)
--- SIGTERM {si_signo=SIGTERM, si_code=SI_USER, si_pid=1, si_uid=0} ---
+++ killed by SIGTERM +++
# service php7.2-fpm status
â php7.2-fpm.service - The PHP 7.2 FastCGI Process Manager
Loaded: loaded (/lib/systemd/system/php7.2-fpm.service; enabled;
vendor preset: enabled)
Active: failed (Result: timeout) since Sun 2018-09-02 09:22:00 CEST;
2min 28s ago
Docs: man:php-fpm7.2(8)
Process: 383 ExecStart=/usr/sbin/php-fpm7.2 --nodaemonize --fpm-config
/etc/php/7.2/fpm/php-fpm.conf (code=killed, signal=TERM)
Main PID: 383 (code=killed, signal=TERM)
Sep 02 09:20:29 debian systemd[1]: Starting The PHP 7.2 FastCGI Process
Manager...
Sep 02 09:22:00 debian systemd[1]: php7.2-fpm.service: Start operation
timed out. Terminating.
Sep 02 09:22:00 debian systemd[1]: php7.2-fpm.service: Failed with
result 'timeout'.
Sep 02 09:22:00 debian systemd[1]: Failed to start The PHP 7.2 FastCGI
Process Manager.
--
Edit bug report at https://bugs.php.net/bug.php?id=76835&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=76835&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=76835&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=76835&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=76835&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=76835&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=76835&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=76835&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=76835&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=76835&r=support
Expected behavior: https://bugs.php.net/fix.php?id=76835&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=76835&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=76835&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=76835&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=76835&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=76835&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=76835&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=76835&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=76835&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=76835&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=76835&r=mysqlcfg