Bug #76835 [Com]: FPM stuck at getrandom()
| From: | spam2 at rhsoft dot net | Date: | Sun, 02 Sep 2018 08:52:42 +0000 |
| Subject: | Bug #76835 [Com]: FPM stuck at getrandom() | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-216846@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=76835&edit=1
ID: 76835
Comment by: spam2 at rhsoft dot net
Reported by: olafvdspek at gmail dot com
Summary: FPM stuck at getrandom()
Status: Open
Type: Bug
Package: FPM related
Operating System: Debian
PHP Version: 7.2.9
Block user comment: N
Private report: N
New Comment:
it's not a bug when you missed to setup your VM proper so that it don't run out of random
install "haveged" and consider what such a setup has for impact on encryption
i recommend replace every certificate generated on that machine, especial ECC is sensible for broken
setups
Previous Comments:
------------------------------------------------------------------------
[2018-09-02 07:25:59] olafvdspek at gmail dot com
Description:
------------
Debian is running in a VM.
At boot, it tries to start php-fpm via systemd. After a minute or so, it times out as php-fpm seems
stuck at a getrandom() call.
Actual result:
--------------
# strace -p 383
strace: Process 383 attached
getrandom(0x7ffd606d51f0, 16, 0) = ? ERESTARTSYS (To be restarted if SA_RESTART is set)
--- SIGTERM {si_signo=SIGTERM, si_code=SI_USER, si_pid=1, si_uid=0} ---
+++ killed by SIGTERM +++
# service php7.2-fpm status
â php7.2-fpm.service - The PHP 7.2 FastCGI Process Manager
Loaded: loaded (/lib/systemd/system/php7.2-fpm.service; enabled; vendor preset: enabled)
Active: failed (Result: timeout) since Sun 2018-09-02 09:22:00 CEST; 2min 28s ago
Docs: man:php-fpm7.2(8)
Process: 383 ExecStart=/usr/sbin/php-fpm7.2 --nodaemonize --fpm-config
/etc/php/7.2/fpm/php-fpm.conf (code=killed, signal=TERM)
Main PID: 383 (code=killed, signal=TERM)
Sep 02 09:20:29 debian systemd[1]: Starting The PHP 7.2 FastCGI Process Manager...
Sep 02 09:22:00 debian systemd[1]: php7.2-fpm.service: Start operation timed out. Terminating.
Sep 02 09:22:00 debian systemd[1]: php7.2-fpm.service: Failed with result 'timeout'.
Sep 02 09:22:00 debian systemd[1]: Failed to start The PHP 7.2 FastCGI Process Manager.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=76835&edit=1