Bug #77361 [NEW]: Configure fails on 64-bit AIX when opcache enabled
| From: | kadler at us dot ibm dot com | Date: | Thu, 27 Dec 2018 22:03:39 +0000 |
| Subject: | Bug #77361 [NEW]: Configure fails on 64-bit AIX when opcache enabled | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-218649@lists.php.net to get a copy of this message | ||
From: kadler at us dot ibm dot com
Operating system: AIX
PHP version: 7.2.13
Package: *Configuration Issues
Bug Type: Bug
Bug description:Configure fails on 64-bit AIX when opcache enabled
Description:
------------
configure fails on 64-bit AIX (or 32-bit with _LARGE_FILES enabled)
*and* --enable-opcache=yes
checking "whether flock struct is linux ordered"... "no"
checking "whether flock struct is BSD ordered"... "no"
configure: error: Don't know how to define struct flock on this system,
set --enable-opcache=no
This is a regression caused by f9048300123, as the configure check was
altered to only check for Linux-style and BSD-style layouts. 32-bit AIX
falls in to the Linux-style layout, so is unaffected. Of the hard-coded
layout macros in ZendAccelerator.h, only 64-bit AIX does not fall in to
the two cases checked for in the configure check.
--
Edit bug report at https://bugs.php.net/bug.php?id=77361&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=77361&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=77361&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=77361&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=77361&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=77361&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=77361&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=77361&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=77361&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=77361&r=support
Expected behavior: https://bugs.php.net/fix.php?id=77361&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=77361&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=77361&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=77361&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=77361&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=77361&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=77361&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=77361&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=77361&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=77361&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=77361&r=mysqlcfg