Bug #77361 [Opn->Csd]: Configure fails on 64-bit AIX when opcache enabled
| From: | nikic@php.net | Date: | Fri, 11 Jan 2019 09:31:23 +0000 |
| Subject: | Bug #77361 [Opn->Csd]: Configure fails on 64-bit AIX when opcache enabled | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-218897@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=77361&edit=1
ID: 77361
Updated by: nikic@php.net
Reported by: kadler at us dot ibm dot com
Summary: Configure fails on 64-bit AIX when opcache enabled
-Status: Open
+Status: Closed
Type: Bug
Package: *Configuration Issues
Operating System: AIX
PHP Version: 7.2.13
Block user comment: N
Private report: N
New Comment:
Automatic comment on behalf of kadler@us.ibm.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=332b58f86591548acd5965c7f7f0085af377f0d9
Log: Fix bug #77361 (configure fails on 64-bit AIX when opcache enabled)
Previous Comments:
------------------------------------------------------------------------
[2018-12-28 00:44:41]
The following pull request has been associated:
Patch Name: Fix bug #77361 (configure fails on 64-bit AIX when opcache enabled)
On GitHub: https://github.com/php/php-src/pull/3723
Patch: https://github.com/php/php-src/pull/3723.patch
------------------------------------------------------------------------
[2018-12-27 22:03:39] kadler at us dot ibm dot com
Description:
------------
configure fails on 64-bit AIX (or 32-bit with _LARGE_FILES enabled) *and* --enable-opcache=yes
checking "whether flock struct is linux ordered"... "no"
checking "whether flock struct is BSD ordered"... "no"
configure: error: Don't know how to define struct flock on this system, set --enable-opcache=no
This is a regression caused by f9048300123, as the configure check was altered to only check for
Linux-style and BSD-style layouts. 32-bit AIX falls in to the Linux-style layout, so is unaffected.
Of the hard-coded layout macros in ZendAccelerator.h, only 64-bit AIX does not fall in to the two
cases checked for in the configure check.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=77361&edit=1