#18609 [Fbk->Csd]: ImageCreateFromJPEG can't fetch from a URL
| From: | derick@php.net | Date: | Wed, 09 Oct 2002 09:02:35 +0000 |
| Subject: | #18609 [Fbk->Csd]: ImageCreateFromJPEG can't fetch from a URL | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-21907@lists.php.net to get a copy of this message | ||
ID: 18609
Updated by: derick@php.net
Reported By: midg3t@mail.com
-Status: Feedback
+Status: Closed
Bug Type: Scripting Engine problem
Operating System: Windows 2000
PHP Version: 4.3.0-dev
Assigned To: wez
New Comment:
PHP 4.3.0 comes with a rewritten filemanagement system (Streams) which
doesn't rely on features that windows didn't implement.
Derick
Previous Comments:
------------------------------------------------------------------------
[2002-10-09 03:54:33] midg3t@mail.com
Thanks for your help, all works fine now.
If it isn't too much trouble to ask, why would the IGNORE_URL_WIN flag
have been used in the past?
------------------------------------------------------------------------
[2002-10-08 08:23:42] sniper@php.net
Did you remember to replace ALL the existing PHP related dlls with the
ones found in the snapshot package?
php4ts.dll and all the extensions and their extra dlls.
------------------------------------------------------------------------
[2002-10-08 06:57:54] midg3t@mail.com
I downloaded that snapshot, maybe because of an error and maybe just
because I don't have very much experience in running a PHP server, I
got this error on starting Apache...
(null)(): Unable to load dynamic library 'C:\Program
Files\PHP\extensions/php_gd.dll' - The specified procedure could not be
found.
The php_gd.dll file is in the extensions directory, so I think it may
have to do with there being a forwardslash instead of backslash. The
extensions directory is configured correctly in my php.ini file.
extension_dir = "C:\Program Files\PHP\extensions"
I apologise if I have made an oversight.
------------------------------------------------------------------------
[2002-09-25 11:31:46] wez@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-latest.zip
The problem is that the GD extension explicitly disables URL access
under windows (it uses the IGNORE_URL_WIN flag when opening the
stream).
Yesterday, I enabled this functionality along with include/require for
remote files.
Please try a snapshot and let us know how you get on.
------------------------------------------------------------------------
[2002-09-25 09:38:22] derick@php.net
streams related...
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/18609
--
Edit this bug report at http://bugs.php.net/?id=18609&edit=1