Bug #78106 [Asn]: PHP Fatal error: Uncaught Error: Class 'Phpfastcache\Config\Config' not found

From: Date: Tue, 11 Jun 2019 12:20:55 +0000
Subject: Bug #78106 [Asn]: PHP Fatal error: Uncaught Error: Class 'Phpfastcache\Config\Config' not found
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-221216@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=78106&edit=1 ID: 78106 Updated by: nikic@php.net Reported by: mbiebl at messageconcept dot com Summary: PHP Fatal error: Uncaught Error: Class 'Phpfastcache\Config\Config' not found Status: Assigned Type: Bug Package: opcache Operating System: Windows Server 2016 / IIS 10 PHP Version: 7.2.19 Assigned To: dmitry Block user comment: N Private report: N New Comment: We're having a hard time reproducing this issue. Could you please provide your opcache ini configuration(s)? I'd also be interested if the people who see this on Debian/Ubuntu are using FPM. Previous Comments: ------------------------------------------------------------------------ [2019-06-06 10:02:25] mbiebl at messageconcept dot com One more observation: The problem only seems to happen if I have at least 2 php-cgi.exe processes. If I have two or more clients access the server at the same time, the failure is triggered immediately. With a single client and only one php-cgi.exe process running, it seems like the failure is not triggered. ------------------------------------------------------------------------ [2019-06-06 09:39:19] mbiebl at messageconcept dot com Once I get this failure, the php process seems to be in a broken state and I then get it on every request. Only thing that helps is then to kill the php process (via iisreset) and let it be respawned. Then it will work again for a while until I hit the problem again at which point only a iisreset help. ------------------------------------------------------------------------ [2019-06-06 09:34:27] mbiebl at messageconcept dot com I have to add that this fatal error is not 100% reproducible here in the sense that I don't get it on every request. If I switch logging from debug to production mode it feels like it takes longer until I hit this error. This smells like a race condition. ------------------------------------------------------------------------ [2019-06-06 02:28:40] ani2life at gmail dot com I'm having a similar problem. PHP-FPM 7.3.6 + Apache 2.4.38 + Ubuntu 18.04 If enable opcache and use require_once, it will Failed opening file. But disable opcache or use require or PHP 7.3.5, it will OK. ------------------------------------------------------------------------ [2019-06-05 16:55:31] mbiebl at messageconcept dot com I also tried php-7.2-nts-windows-vc15-x86-rad63bd1.zip, which seems to be the last successful build before https://github.com/php/php-src/commit/5c4d125d4c2976236e2ecddd1d8c6e7b113ec482#diff-c71a95c83b8c6641638e6732d2264b55 No problems with this version, which would confirm that this commit is indeed the culprit ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=78106 -- Edit this bug report at https://bugs.php.net/bug.php?id=78106&edit=1

« previous php.bugs (#221216) next »