Bug #78106 [Asn]: PHP Fatal error: Uncaught Error: Class 'Phpfastcache\Config\Config' not found

From: Date: Tue, 11 Jun 2019 19:59:24 +0000
Subject: Bug #78106 [Asn]: PHP Fatal error: Uncaught Error: Class 'Phpfastcache\Config\Config' not found
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-221231@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=78106&edit=1 ID: 78106 User updated by: mbiebl at messageconcept dot com Reported by: mbiebl at messageconcept dot com Summary: PHP Fatal error: Uncaught Error: Class 'Phpfastcache\Config\Config' not found Status: Assigned Type: Bug Package: opcache Operating System: Windows Server 2016 / IIS 10 PHP Version: 7.2.19 Assigned To: dmitry Block user comment: N Private report: N New Comment: How can I find out if there was an opcache restart? Is there a way to get a more verbose debug log from the opcache module? Previous Comments: ------------------------------------------------------------------------ [2019-06-11 13:28:31] nikic@php.net Thanks for the information! If this issue only occurs sporadically, is there any correlation with opcache restarts? That is, does the error occur around the same time that an opcache restart even occurs? ------------------------------------------------------------------------ [2019-06-11 13:26:42] dmitry@php.net May be this patch can help https://gist.github.com/dstogov/b13163408e0edf337b99b4e634cba38f But it's really hard to guess, without a way to reproduce the problem. ------------------------------------------------------------------------ [2019-06-11 13:08:48] michel at weimerskirch dot net I was lead to this issue from here: https://github.com/php/php-src/pull/4161 Our setup on the affected machines is PHP 7.2.19 or 7.3.6 with opcache enabled. Deactivating opcache or going back to 7.2.18 or 7.3.5 also "solve" the problem for us, just like for the user "ani2life". As to the ini configuration, we tried a few combinations, but even with everything set to default the error sometimes appears. Yes, we run FPM on Ubuntu. ------------------------------------------------------------------------ [2019-06-11 12:20:54] nikic@php.net We're having a hard time reproducing this issue. Could you please provide your opcache ini configuration(s)? I'd also be interested if the people who see this on Debian/Ubuntu are using FPM. ------------------------------------------------------------------------ [2019-06-06 10:02:25] mbiebl at messageconcept dot com One more observation: The problem only seems to happen if I have at least 2 php-cgi.exe processes. If I have two or more clients access the server at the same time, the failure is triggered immediately. With a single client and only one php-cgi.exe process running, it seems like the failure is not triggered. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=78106 -- Edit this bug report at https://bugs.php.net/bug.php?id=78106&edit=1

« previous php.bugs (#221231) next »