Bug #78772 [NEW]: Session after destroy doesn't show up as destroyed and causes 500 error

From: Date: Sat, 02 Nov 2019 09:11:04 +0000
Subject: Bug #78772 [NEW]: Session after destroy doesn't show up as destroyed and causes 500 error
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-223549@lists.php.net to get a copy of this message
From: 2210416236 at gitam dot in Operating system: Windows Server 2008 R2 SP1 PHP version: 7.3.11 Package: IIS related Bug Type: Bug Bug description:Session after destroy doesn't show up as destroyed and causes 500 error Description: ------------ In PHP Version 7.3.11 for IIS on Windows Server 2008 R2 SP1, the session_start() doesn't detect a Session Variable and throws an error. Even after the error is handled the program fails and throws a 500 error. A temporary fix was to set all initial variable to NULL but that wasn't the case until the previous version of PHP. -- Edit bug report at https://bugs.php.net/bug.php?id=78772&edit=1 -- Fix committed: https://bugs.php.net/fix.php?id=78772&r=fixed Fixed in release: https://bugs.php.net/fix.php?id=78772&r=alreadyfixed Need backtrace: https://bugs.php.net/fix.php?id=78772&r=needtrace Need Reproduce Script: https://bugs.php.net/fix.php?id=78772&r=needscript Try newer version: https://bugs.php.net/fix.php?id=78772&r=oldversion Not developer issue: https://bugs.php.net/fix.php?id=78772&r=support Expected behavior: https://bugs.php.net/fix.php?id=78772&r=notwrong Not enough info: https://bugs.php.net/fix.php?id=78772&r=notenoughinfo Submitted twice: https://bugs.php.net/fix.php?id=78772&r=submittedtwice register_globals: https://bugs.php.net/fix.php?id=78772&r=globals PHP version support discontinued: https://bugs.php.net/fix.php?id=78772&r=phptooold Daylight Savings: https://bugs.php.net/fix.php?id=78772&r=dst IIS Stability: https://bugs.php.net/fix.php?id=78772&r=isapi Install GNU Sed: https://bugs.php.net/fix.php?id=78772&r=gnused Floating point limitations: https://bugs.php.net/fix.php?id=78772&r=float No Zend Extensions: https://bugs.php.net/fix.php?id=78772&r=nozend MySQL Configuration Error: https://bugs.php.net/fix.php?id=78772&r=mysqlcfg

« previous php.bugs (#223549) next »