Bug #78772 [Fbk->NoF]: Session after destroy doesn't show up as destroyed and causes 500 error

From: Date: Sun, 10 Nov 2019 04:22:05 +0000
Subject: Bug #78772 [Fbk->NoF]: Session after destroy doesn't show up as destroyed and causes 500 error
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-223664@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=78772&edit=1 ID: 78772 Updated by: php-bugs@lists.php.net Reported by: 2210416236 at gitam dot in Summary: Session after destroy doesn't show up as destroyed and causes 500 error -Status: Feedback +Status: No Feedback Type: Bug Package: IIS related Operating System: Windows Server 2008 R2 SP1 PHP Version: 7.3.11 Private report: N New Comment: No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Re-Opened". Thank you. Previous Comments: ------------------------------------------------------------------------ [2019-11-02 09:17:39] cmb@php.net Thank you for this bug report. To properly diagnose the problem, we need a short but complete example script to be able to reproduce this bug ourselves. A proper reproducing script starts with <?php and ends with ?>, is max. 10-20 lines long and does not require any external resources such as databases, etc. If the script requires a database to demonstrate the issue, please make sure it creates all necessary tables, stored procedures etc. Please avoid embedding huge scripts into the report. ------------------------------------------------------------------------ [2019-11-02 09:11:04] 2210416236 at gitam dot in Description: ------------ In PHP Version 7.3.11 for IIS on Windows Server 2008 R2 SP1, the session_start() doesn't detect a Session Variable and throws an error. Even after the error is handled the program fails and throws a 500 error. A temporary fix was to set all initial variable to NULL but that wasn't the case until the previous version of PHP. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=78772&edit=1

« previous php.bugs (#223664) next »