Bug #78892 [NEW]: php-fpm: 7.4.0 chown() the socket Operation not permitted
| From: | ilya at ilya dot pp dot ua | Date: | Sat, 30 Nov 2019 13:31:21 +0000 |
| Subject: | Bug #78892 [NEW]: php-fpm: 7.4.0 chown() the socket Operation not permitted | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-223965@lists.php.net to get a copy of this message | ||
From: ilya at ilya dot pp dot ua
Operating system: openSUSE Tumbleweed
PHP version: 7.4.0
Package: *Configuration Issues
Bug Type: Bug
Bug description:php-fpm: 7.4.0 chown() the socket Operation not permitted
Description:
------------
After upgrade to 7.4.0
listen = /run/php-fpm.sock
listen.owner = nginx
listen.group = nginx
listen.mode = 0600
ERROR: [pool php] failed to chown() the socket '/run/php-fpm.sock':
Operation not permitted (1)
work only
listen = /run/php-fpm.sock
;listen.owner = nginx
;listen.group = nginx
listen.mode = 0666
Why it happens?
ArchLinux has the same problem.
https://bugs.archlinux.org/task/64683
Test script:
---------------
php-fpm:
listen = /run/php-fpm.sock
listen.owner = nginx
listen.group = nginx
listen.mode = 0600
Expected result:
----------------
Started The PHP FastCGI Process Manager
Actual result:
--------------
Starting The PHP FastCGI Process Manager...
ERROR: [pool php] failed to chown() the socket '/run/php-fpm.sock':
Operation not permitted (1)
ERROR: FPM initialization failed
Main process exited, code=exited, status=78/CONFIG
php-fpm.service: Failed with result 'exit-code'.
Failed to start The PHP FastCGI Process Manager.
--
Edit bug report at https://bugs.php.net/bug.php?id=78892&edit=1
--
Fix committed: https://bugs.php.net/fix.php?id=78892&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=78892&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=78892&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=78892&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=78892&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=78892&r=support
Expected behavior: https://bugs.php.net/fix.php?id=78892&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=78892&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=78892&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=78892&r=globals
PHP version support discontinued: https://bugs.php.net/fix.php?id=78892&r=phptooold
Daylight Savings: https://bugs.php.net/fix.php?id=78892&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=78892&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=78892&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=78892&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=78892&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=78892&r=mysqlcfg